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CHAPTER 1 INTRODUCTION

1.1 Introduction

This Application Guide helps you to get started with AMASS quickly.

The examples in this Application Guide show you how to use the software to do simple tasks.

For all the tasks in the examples, there can be other possible ways to complete them, but then you
must experiment with AMASS and learn the other possibilities yourself.

There can be differences between the example screens in this Application Guide and what you see
on your screen. If that occurs, follow the instructions on your screen.

1.2 Contents of the Application Guide

These are the worked examples used in this Application Guide:

Chapter 2: Measure composition and thickness from a rocking curve

This chapter gives information about how to plot a rocking curve and find the layer thicknesses
and compositions from marked peak positions in rocking curves from cubic semiconductor
samples.

Chapter 3: Find the thickness of a layer from a specular reflectivity curve

This chapter gives information about how to open a measured data file and use 2 different
methods to evaluate the thickness of a layer.

Chapter 4: Make and edit sample information

This chapter gives information about how to make sample files for samples with more than one
layer and how to link layers. The sample files are necessary when you use the automatic fit
functionality. The chapter is divided into 4 independent sections; one for each of the major sample
types supported: SiGe alloy structures, III-V alloy structures and 2 hexagonal nitride materials.

Chapter 5: Use graphics with area scans

This chapter gives information about how to load and show area data and mark peaks for area
scans. Information is also given about how to merge area scans, and how to extract single scans
from an area scan and project an area scan as a single scan.

Chapter 6: Find composition and relaxation from rocking curves

This chapter gives information about how to find layer composition and relaxation for
semiconductor samples from a set of rocking curves.

Chapter 7: Find composition and relaxation from maps

This chapter gives information about how to find layer composition and relaxation for
semiconductor samples from a set of reciprocal space maps.

Chapter 8: Make simulations and use automatic fitting of rocking curves

This chapter gives information about how to simulate a rocking curve and use automatic fitting.

Chapter 9: Make simulations and use automatic fitting of specular reflectivity curves

6



This chapter gives information about how to simulate a specular reflectivity curve and use
automatic fitting.

Chapter 10: Make a wafer map from a set of diffraction data

This chapter gives information about how to use the AMASS Wafer Map function to make maps
that show the variation in a sample parameter (for example, substrate peaks width or layer
mismatch) as a function of position on the wafer from a set of diffraction data.

Chapter 11: Diffuse scatter

This chapter gives information about how to open an omega scan and find out what Hurst
parameter and lateral correlation lengths are used best for the sample.

Chapter 12: Automate your diffraction measurements and analyses

This chapter gives information about how to automate your analyses with AMASS directly from the
command line or use the AMASS Controller application.

1.3 Start AMASS

To start AMASS, use one of these procedures:

• On the desktop, double-click the icon .

• Click the Windows Start button and then on the list of apps or programs, go to
PANalytical AMASS > AMASS.

CHAPTER 1 INTRODUCTION
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1.4 Customize AMASS

1.4.1 Customize the default parameters

A wide range of default parameters can be set in the Settings menu:

• Options for calculations and to show wafer maps

• Default peak search and labeling when scans are opened or on scan simulations

• Default substrate and layer materials for sample files

• Default convolution parameters for simulated scans

• Default fitting parameters for automatic fitting

• Default plot settings for single and area scans

• Options for the direct analysis of opened single and area scans

• Defaults for the used length units and the number of decimal places of parameters

1.4.2 Customize the toolbar

1. Right-click on the menu bar or toolbar and select Customize. The Customize window has 3
tabs where you can customize the toolbar.

NOTE: The default menu bar and toolbar cannot be renamed or deleted.

2. If you want to add a command to the toolbar, do as follows:

a. Go to the Commands tab.

b. Drag and drop the command that you want to add to the toolbar.

3. If you want to remove a command from the toolbar, do as follows:

a. Make sure that the Customize window is open.

b. Drag and drop the command that you want to remove away from the toolbar.

4. If you want to reset the toolbar to its original settings, do as follows:

a. Go to the Toolbars tab.

b. Select the ToolBar check box.

c. Click Reset.

d. Click OK.

5. If you want to make your own toolbar, do as follows:

a. Go to the Toolbars tab.

b. Click New.

c. In the Toolbar Name field, enter a name. For example, "My Toolbar".

d. Click OK. My Toolbar is added to the list and there is a small box under the default toolbar
which is the new toolbar.

e. If you want to move the new toolbar, drag and drop it to the new position.

f. Go to the Commands tab.

g. Drag and drop the commands that you want to use in the toolbar.

Figure 1.1 My Toolbar

8



6. If you want to hide or show toolbars, do as follows:

a. Go to the Toolbars tab.

b. Clear or select the check boxes of the toolbars that you want to hide or show.

7. If you want the toolbar buttons shown as large icons, do as follows:

a. Go to the Options tab.

b. Select the Large icons check box.

8. Click OK to close the Customize window.

9. If you want to hide or show buttons on the customized toolbar, do as follows:

a. Click the arrow button  at the end of the toolbar.

b. Click Add or Remove Buttons.

c. Click the button that you want to hide or show.

1.5 Data files used in this Application Guide

Data files that are used in the exercises of this Application Guide are supplied with the software.
The files are installed in your Documents folder: C:Users\User.Name\Documents\PANalytical
\AMASS\Examples.

Table 1.1 Data files

Chapter Data file

Chapter 2 004 GeSi on Ge.xrdml

Chapter 3 SiGe_Si_XRR.x00

Chapter 5 SBTN fibre.A00, Multi_2.A01, Multi_2.A02

Chapter 6 GaInAs004a.d00, GaInAs004b.d00, GaInAs224a.d00, GaInAs224b.d00

Chapter 7 Map004a.a00, Map004b.a00, Map444a.a00, "Map444b.a00

Chapter 8 SiGe.d00, GaN_MQW.aprjxl, GaN.d00

Chapter 9 XRR-1.x00

Chapter 10 X_Y_1.xrdml, X_Y_4.xrdml, InP_Q.asamxl, InP_Q.d00 to InP_Q.d35

Chapter 11 QSG11.asamxl

CHAPTER 1 INTRODUCTION
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CHAPTER 2 MEASURE COMPOSITION

AND THICKNESS FROM A ROCKING

CURVE

2.1 Introduction

This chapter gives information about how to show a rocking curve from a single crystal substrate
with a heteroepitaxial layer and find the composition and thickness of the layer.

This example uses an 004 rocking curve from a (001) germanium substrate with a strained
heteroepitaxial layer of germanium silicon recorded with an X'Pert PRO MRD. The scan file "004
GeSi on Ge.xrdml" is an ω/2θ scan which was recorded with a mirror plus a Ge 220 4‑crystal
monochromator as primary optics modules and with a receiving slit as secondary optics module.

2.2 Set the sample defaults
1. Start AMASS.

2. Go to View > View as H.R. diffraction.

3. Set the substrate as follows:

a. Go to Settings > Application Settings.

b. Go to the Sample Defaults tab.

c. In the Default substrate frame, select Diamond from the Structure drop-down list.

d. In the Default substrate frame, select Ge from the Material drop-down list. The list only
contains materials that are part of the chosen structure type.

4. Set the layer as follows:

a. In the Default layer frame, select Diamond from the Structure drop-down list.

b. In the Default layer frame, select Si(x)Ge(1-x) from the Material drop-down list.

c. If applicable, change the default values for thickness and composition.

d. If applicable, select the Use percentages to set fitting ranges check box. When this
check box is selected, you can change the percentage values that will be used to set the
fitting ranges.

10



Figure 2.1 Sample Defaults tab for GeSi layer

e. Go to the Direct Analysis Defaults tab.

f. In the Substrate HKL field, enter "0 0 4".

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

g. In the Layer HKL field, enter "0 0 4"

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

5. In the Automatic peak marking on opening scans frame, select the Peak label check box
for Measured 1-axis scans.

CHAPTER 2 MEASURE COMPOSITION AND THICKNESS FROM A ROCKING CURVE
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Figure 2.2 Direct Analysis Defaults tab for GeSi layer

6. Click OK to save the settings and close the window.

2.3 Make a new sample
1. Go to Sample > New Sample. At the bottom of the screen, the New Sample Editor tab

opens with the default material of the substrate. If necessary, this can be edited.

2. In the Layers pane, click Add Layer. The substrate layer moves down 1 row and the new layer
is the top row. The default material and parameters are used. Relaxation is set to 0 %.

3. If necessary, edit the material, alloy composition, thickness or relaxation.

2.4 Set default peak labeling

Set peak search and peak labeling rules for the layer, substrate peaks and 2 thickness fringes:

1. Go to the 1-axis Peak Search Details tab.

CHAPTER 2 MEASURE COMPOSITION AND THICKNESS FROM A ROCKING CURVE
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2. Click Add. A window opens where you can edit the rules for labeling peaks.

3. In the Name field, enter "S-L-F-F".

4. Click Add rule 3 times to add 3 rules.

5. Use these settings:

Figure 2.3 Edit Peak Labeling Rules window

6. Click OK. When a measured scan is loaded, peak positions are marked with vertical lines. The
substrate and layer peaks are marked "S" and "L" respectively and the 2 thickness fringes are
labeled "F".

2.5 Open measured data
1. Set the default single scan options as follows:

a. Go to Settings > Default Single Scan Plot Settings.

b. In the Intensity scale field, select Logarithmic.

c. In the Intensity units field, select cps.

d. In the Show x axis as field, select the correct setting:

• Select Absolute angle (deg) if you want to plot in degrees.

• Select Relative seconds if you want to plot in seconds.

e. Click OK to close the window.

2. Go to File > Open Scan(s).
3. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

4. Select "004 GeSi on Ge.xrdml".

5. Click Open. The scan data shows in a single scan graphics window.

CHAPTER 2 MEASURE COMPOSITION AND THICKNESS FROM A ROCKING CURVE
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Figure 2.4 Graph area in relative seconds

The file name is shown in the Scan List tab on the left of the screen. The scan information can
be found in the Scan Properties tab. If you cannot see these areas, go to View and select
them.

6. If you want to adjust the plot, do as follows:

• To zoom in, click and drag the cursor to zoom in into that area. Horizontal and vertical scroll
bars are available to move around the full area of the plotted data. Double-click or click 
to see the full-size plot. To go back to the previous size, click .

• To change the intensity scaling settings to linear, square root or logarithmic or to change
other relevant single scan settings, click . You can also use the Intensity scale in the

toolbar .

• To change between plot in degrees or plot in relative seconds, click  (degrees) or 
(relative seconds).

• To change between plot intensity in counts or counts per second, click .

• To change the color of the plot, double-click the color symbol in the Scan List tab, select
the new color and then click OK.

• To change the plot style and line style, click .

2.6 Find the layer composition and thickness
1. Go to the Results Summary tab.

2. Select the Use materials from selected sample layers check box.

CHAPTER 2 MEASURE COMPOSITION AND THICKNESS FROM A ROCKING CURVE
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Figure 2.5 Results Summary pane

The layer and substrate peak positions, intensities and half widths are given together with
values of the layer thickness. There are 2 values supplied for the mismatch and composition; 1
value is for a fully relaxed layer and 1 value is for the fully strained layer. As the thickness
fringes are very clear, the layer is apparently fully strained, thus the fully strained value is the
correct value for this sample.

This procedure is the peak position based method to find the composition and mismatch for a
cubic sample. As an alternative, use the fitting procedure. Refer to Chapter 8.

For more information about how to interpret single scans with the used equations, refer to the
AMASS Help. You can also mark all the fringes on the right side of the layer peak to find the
layer thickness more accurately. This information is also given in the AMASS Help.

2.7 Set up a report
1. Go to Report > Report Setup.

2. In the Available report items field, select the item that you want to include in the report.

3. Click .

4. Go back to step 2 until you have added all the items that you want to include in the report.

5. Click OK.

6. If you want to print the report, go to Report > Print Report.

7. If you want to save the report, go to Report > Save Report To File As and select the format
that you want to save the report as.

2.8 Prepare for work on equivalent samples

If this sample was the first of many equivalent samples to be measured, you can save the sample
file and the INI file to automate the analysis of further samples. Refer to Chapter 12.

1. Go to the Results Summary tab.

2. Click Update sample.

3. Select Strained composition values and the Update thickness check box.

4. Click OK to change the layer details into the sample definition.

CHAPTER 2 MEASURE COMPOSITION AND THICKNESS FROM A ROCKING CURVE

15



5. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter "GeSi on Ge.asamxl".

c. Click Save to save the sample details as a sample file.

6. Save the default settings in an INI file for future use:

a. Go to Settings > Save Settings As.

b. In the File name field, enter "ResSum.ini".

c. Click Save to save the default settings in an INI file.

7. As an alternative, you can also save all settings including all data in a project file. Do as follows:

a. Go to File > Save Project As.

b. In the File name field, enter "ResSum.aprjxl".

c. Click Save.

CHAPTER 2 MEASURE COMPOSITION AND THICKNESS FROM A ROCKING CURVE
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CHAPTER 3 FIND THE THICKNESS OF A

LAYER FROM A SPECULAR

REFLECTIVITY CURVE

3.1 Introduction

This chapter gives 2 different methods to examine the thickness of the layer of SiGe on a Si
substrate:

• Fourier method

• Direct method

3.2 Open measured data
1. Start AMASS.

2. Go to File > Open Scan(s).
3. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

4. Select "SiGe_Si_XRR.x00".

5. Click Open.

3.3 Use the Fourier method
1. Go to the Specular Thickness Analysis tab. If the tab is not shown in the results and working

area, go to View > Specular Thickness Analysis.

Figure 3.1 Specular Thickness Analysis tab

There are 2 frames in this tab, Direct Method and Fourier Method. In this section, the
Fourier method is used to find the thickness of the SiGe layer.

2. On the main scan, drag the cursor line to the critical angle. If the cursor line is not visible, click
.

17



Figure 3.2 Cursor line at the critical angle

3. Right-click at the critical angle and go to Specular Thickness Analysis > Define Cursor
Position as Critical Angle. The position is shown in the Critical angle (deg) field in the
Specular Thickness Analysis tab. To show the manually set cursor position, select the Show
positions on the selected scan check box.

4. If applicable, select the Set start and end angles automatically check box. The start and
end angle values are taken from the open scan. The 2 positions can also be set by the cursor:

a. To set the start angle, right-click and go to Specular Thickness Analysis > Define Cursor
Position as Fourier Analysis Start Angle.

b. To set the end angle, right-click and go to Specular Thickness Analysis > Define Cursor
Position as Fourier Analysis End Angle.

5. Select the Automatically mark thicknesses check box. The related thicknesses are shown
in the Marked thicknesses table.

6. If you want to change the peak search criteria, do as follows:

a. Click Settings.

b. Change the peak search criteria.

c. Click OK.

7. In the Specular Thickness Analysis tab, click and drag the cursor on the peak to zoom in.

8. Move the cursor line to the top of the peak.

9. Right-click and select Mark Cursor Position as Thickness. The result is shown in the
Marked thicknesses table. In this experiment, the thickness is measured at 69.1 nm.

Figure 3.3 Marked thicknesses table

3.4 Use the direct method

The direct method measures the distance between 2 fringes to find the thickness of the layer.

CHAPTER 3 FIND THE THICKNESS OF A LAYER FROM A SPECULAR REFLECTIVITY CURVE
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1. On the main scan, zoom into an area with clearly defined peaks or valleys.

2. Move the cursor to a peak or valley.

Figure 3.4 Main scan zoomed in

3. Right-click and go to Specular Thickness Analysis > Define Cursor Position as First
Fringe Angle.

4. Move the cursor to the next peak or valley.

5. Right-click and go to Specular Thickness Analysis > Define Cursor Position as Second
Fringe Angle. The results are shown in the Direct Method frame. In this example, the
thickness is 69.144 nm.

Figure 3.5 Direct Method frame

The results of the Fourier method and the direct method are very close. It shows that the thickness
is approximately 69 nm.

NOTE: If you need a more accurate result, you need the average of more adjacent fringes (4, 6, 8,
and so on). If more fringes are used, the result must be multiplied by the number of fringes
used.

CHAPTER 3 FIND THE THICKNESS OF A LAYER FROM A SPECULAR REFLECTIVITY CURVE
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CHAPTER 4 MAKE AND EDIT SAMPLE

INFORMATION

4.1 Introduction

This chapter gives information about how to make sample files which are used to keep information
about semiconductor epitaxial layer structures. Sample files are necessary for the results and
simulate functions. The chapter is divided into 4 independent parts, 1 for each of the main
materials combinations supported by AMASS.

These are the demonstrations samples:

• Sample A: A silicon substrate with a SiGe graded layer plus a Si capping layer.

• Sample B: A quaternary multiquantum well device structure on an InP substrate.

• Sample C: A GaN/GaInN superlattice on a sapphire substrate.

• Sample D: An InGaN layer on GaN substrate (or buffer layer) with a‑plane orientation

For each sample, the default substrate and layer must be set and the sample file must be made.

For samples B and C, layer linking procedures are also given.

4.2 Sample A (Si substrate)

This is the sample structure used for the sample file in this example:

Figure 4.1 Sample structure

1. Start AMASS.

2. Go to View > View as H.R. diffraction.

3. Set the substrate as follows:

a. Go to Settings > Application Settings.

b. Go to the Sample Defaults tab.

c. In the Default substrate frame, select Diamond from the Structure drop-down list.
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d. In the Default substrate frame, select Si from the Material drop-down list. The list only
contains materials that are part of the chosen structure type.

4. Set the layer as follows:

a. In the Default layer frame, select Diamond from the Structure drop-down list.

b. In the Default layer frame, select Si(x)Ge(1-x) from the Material drop-down list.

c. If applicable, change the default values for thickness and composition.

d. If applicable, select the Use percentages to set fitting ranges check box. When this
check box is selected, you can change the percentage values that will be used to set the
fitting ranges.

Figure 4.2 Sample defaults for GeSi layer

e. Go to the Direct Analysis Defaults tab.

f. In the Substrate HKL field, enter "0 0 4".

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

CHAPTER 4 MAKE AND EDIT SAMPLE INFORMATION

21



g. In the Layer HKL field, enter "0 0 4"

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

Figure 4.3 Direct Analysis Defaults tab

5. Click OK to save the settings and close the window.

6. Go to Sample > New Sample. At the bottom of the screen, the New Sample Editor tab
opens with the default material of the substrate.

7. Add the first layer:

a. In the Layers pane, click Add Layer.

b. In the Layer Details pane, expand Grading Details.

c. In the Grading Type field, select Linear.

d. In the No. of Laminae field, enter "5".

e. In the Value (x) field of Top Alloy Comp. x Details, enter "0.995".

f. In the Value (x) field of Bottom Alloy Comp. x Details, enter "0.82".

g. In the Value (nm) field of Thickness Details, enter "57".

CHAPTER 4 MAKE AND EDIT SAMPLE INFORMATION

22



8. Add the second layer:

a. In the Layers pane, click Add Layer.

b. In the Material column, select Si [Diamond] from the drop-down list

c. In the Thickness (nm) column, enter "8".

9. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter "Sample A.asamxl".

c. Click Save.

4.3 Sample B (InP substrate)

This is the sample structure used for the sample file in this example:

Figure 4.4 Device structure with 7 quantum wells on InP

The sample has an (001) indium phosphide substrate and capping layer, with alternating layers of
2 different compositions of indium gallium phosphide arsenide (GaxIn(1-x)AsyP(1-y)). The x‑values
and y‑values for the 2 quaternaries are: QA x=0.3236, y=0.5000; QB x=0.196, y=0.8000. To make
the sample model, the sample must be divided into layers as shown on the right side of the figure.

Table 4.1 Layer thicknesses in microns

Layer Material Thickness

0 InP 250000

1 QA 10

2 7 periods 147

2.0 QB 7

2.1 QA 14

3 QB 7

4 QA 10

5 InP 100

 

1. Set the substrate as follows:

a. Go to Settings > Application Settings.

b. Go to the Sample Defaults tab.

c. In the Default substrate frame, select ZincBlende from the Structure drop-down list.
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d. In the Default substrate frame, select InP from the Material drop-down list. The list only
contains materials that are part of the chosen structure type.

e. In the Value column of the Thickness (nm) row, enter "250000" (necessary for layer 0).

2. Set the layer as follows:

a. In the Default layer frame, select ZincBlende from the Structure field.

b. In the Default layer frame, select Ga(x)In(1-x)As(y)P(1-y) from the Material field.

c. In the Value column of the Thickness (nm) row, enter 10" (necessary for layers 1 and 4).

d. In the Value column of the Alloy Comp. x row, enter "0.3236" for the fraction of Ga.

e. In the Value column of the Alloy Comp. y row, enter "0.5" for the fraction of As.

f. If applicable, select the Use percentages to set fitting ranges check box. When this
check box is selected, you can change the percentage values that will be used to set the
fitting ranges.

Figure 4.5 Sample Defaults tab

g. Go to the Direct Analysis Defaults tab.

CHAPTER 4 MAKE AND EDIT SAMPLE INFORMATION

24



h. In the Substrate HKL field, enter "0 0 4".

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

i. In the Layer HKL field, enter "0 0 4".

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

Figure 4.6 Direct Analysis Defaults tab

3. Click OK to save the settings and close the window.

4. Go to Sample > New Sample. At the bottom of the screen, the New Sample Editor tab
opens with the default material of the substrate.

5. In the Layers pane, click Add Layer to add layer 1.

6. Add layer 2 as follows:

a. In the Layers pane, click Add Superlattice.

b. Select Layer No. 2 Superlattice.

c. In the Number of repeats field of the Superlattice Details pane, enter "7".
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7. A default zinc blende layer has been entered as the first layer of the superlattice (SL Repeat
unit 0). We must add a second layer (SL repeat unit 1) to the superlattice. Do as follows:

a. Select SL Repeat Unit 0.

b. In the Layers pane, click Add Layer.

8. Edit the composition and thickness of SL repeat layer 0 and the thickness of SL repeat unit 1:

a. In the Thickness (nm) field of SL Repeat Unit 0, enter "7".

b. In the Alloy Comp. x field, enter "0.196" for Ga.

c. In the Alloy Comp. y field, enter "0.5" for As.

d. In the Thickness (nm) field of SL Repeat Unit 1, enter "14".

9. Use copy and paste to add layer 3 and layer 4 as they are the same as layer 2.0 and layer 1:

a. Right-click Rep. Unit No. 0 and select Copy Layer.

b. Right-click Layer No. 2 and select Paste as Next Layer.

c. Right-click Layer No. 1 and select Copy Layer.

d. Right-click Layer No. 3 and select Paste as Next Layer.

10. Add InP cap as layer 5:

a. In the Layers pane, click Add Layer.

b. From the Material drop-down list, select InP [ZincBlende].
c. In the Thickness (nm) field, enter "100".

11. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter "Sample B.asamxl".

c. Click Save.

4.3.1 Set up links

These links will be set up for this sample:

• Standard links between compositions x of all the layers of composition QA.

• Standard links between compositions x of all the layers of composition QB.

• Total link for the layer thickness of layers 2.0 and 2.1.

When these links have been set up, the Ga composition x of all the QA layers and all the QB layers
will all change together when one of the layers is edited. The combined thickness of layers 2.0 and
2.1 will stay constant when the thickness of either layer is edited. These links are saved in the
sample file and will be active when edited manually and when automatic fitting is used.

1. In the Layers pane, click Link layers.

2. Press Ctrl  and then select these layers:

• Layer: 1, 0 Comp. x
• Layer: 2, 1 Comp. x
• Layer: 4, 0 Comp. x

3. Click Standard link to make a link between these layers.

4. Select these layers:

• Layer: 2, 0 Comp. x
• Layer: 3, 0 Comp. x
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5. Click Standard link.

6. Select these layers:

• Layer: 2, 0 Thickness
• Layer: 2, 1 Thickness

7. Click Total link.

Figure 4.7 Link Layers window

8. Click OK. A new column Links is added to the sample table to show which parameters of
which layers are linked.

Figure 4.8 Sample Data window for Sample B

9. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter "Sample B.asamxl".

c. Click Save.

4.4 Sample C (sapphire substrate)

This is the sample structure used for the sample file in this example:
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Figure 4.9 Sample with sapphire substrate

For this sample, the interface between the sapphire and the GaN buffer layer is assumed as totally
relaxed.

1. Set the substrate as follows:

a. Go to Settings > Application Settings.

b. Go to the Sample Defaults tab.

c. In the Default substrate frame, select Sapphire from the Structure drop-down list.

d. In the Default substrate frame, select Al2O3 from the Material drop-down list. The list
only contains materials that are part of the chosen structure type. In this case, only Al2O3 is
possible.

2. Set the layer as follows:

a. In the Default layer frame, select Wurtzite from the Structure drop-down list.

b. In the Default layer frame, select In(x)Ga(1-x)N from the Material drop-down list.

c. In the Value column of the Thickness (nm) row, enter "100".

d. In the Value column of Alloy Comp. x, enter "0.13".
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Figure 4.10 Sample Defaults tab

e. Go to the Direct Analysis Defaults tab.

f. In the Substrate HKL field, enter "0 0 6".

NOTE: Make sure that you enter the value as 0, space, 0, space, 6.

g. In the Layer HKL field, enter "0 0 2"

NOTE: Make sure that you enter the value as 0, space, 0, space, 2.
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Figure 4.11 Direct Analysis Defaults tab

3. Click OK to save the settings and close the window.

4. Go to Sample > New Sample. At the bottom of the screen, the New Sample Editor tab
opens with the default material of the substrate.

5. Enter the fully relaxed GaN buffer layer which is 1.5 microns thick:

a. In the Layers pane, click Add Layer. A 0.1 micron In0.5GaN0.5N layer is added as we set in
the defaults.

b. From the Material drop-down list, select GaN [Wurtzite].
c. In the Thickness (nm) field, enter "1500".

d. In the HR Parameters field of Layer Details, click the arrow.

e. Clear the Couple Y direction relaxation to X direction check box.

f. Click OK.

g. In the Layer Details pane, expand Relaxation Details and Relaxation Y Details.

h. In the both Value (%) fields, enter "100".
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6. Enter the superlattice which contains 10 repeats of 2.5 nm of In0.13 Ga0.87N plus 7 nm of GaN:

a. In the Layers pane, click Add Superlattice.

b. Select Layer No. 2.

c. In the Number of repeats field, enter "10".

7. A default wurtzite layer has been entered as the first layer of the superlattice (layer 2.0). We
must add a second layer to the superlattice:

a. Select SL Repeat unit 0.

b. In the Layers pane, click Add Layer.

c. In the Alloy Comp. x field of SL Repeat unit 0, make sure that "0.13" is shown.

d. In the Thickness (nm) field, enter "2.5".

e. In the Relax X, Y(%) field, enter "0".

f. From the Material drop-down list of SL Repeat unit 1, select GaN [Wurtzite].
g. In the Thickness (nm) field, enter "7.0".

h. In the Relax (%) field, enter "0".

8. Add the 50 nm GaN capping layer:

a. Select Layer No. 2.

b. In the Layers pane, click Add Layer.

c. From the Material drop-down list, select GaN [Wurtzite].
d. In the Thickness (nm) field, enter "50".

e. In the Relax (%) fields, enter "0".

9. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter "Sample C.asamxl".

c. Click Save.

4.4.1 Set up links

For this sample, 1 total link can be added to fix the superlattice period. This link is saved in the
sample file and will be active when edited manually and when automatic fitting is used. Refer to
Chapter 8.

1. In the Layers pane, click Link layers.

2. Press Ctrl  and then select these layers:

• Layer: 2, 0 Thickness
• Layer: 2, 1 Thickness

3. Click Total link.
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Figure 4.12 Link Layers window

4. Click OK.

5. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter "Sample C.asamxl".

c. Click Save.

4.5 Sample D (a-plane GaN)

This is the sample structure used for the sample file in this example:

Figure 4.13 A-plane GaN sample

For this sample the relaxation along the x-directions and y-directions are different. The sample
substrate is a GaN virtual substrate. It is assumed to be equivalent to a totally relaxed buffer layer
on any substrate. A single partially relaxed InGaN layer is on top of the GaN.

1. Set the substrate as follows:

a. Go to Settings > Application Settings.

b. Go to the Sample Defaults tab.

c. In the Default substrate frame, select Wurtzite from the Structure drop-down list.

d. In the Default substrate frame, select GaN from the Material drop-down list. The list only
contains materials that are part of the chosen structure type.

e. In the Value column of the Thickness (nm) row, enter "200000".

2. Set the layer as follows:

a. In the Default layer frame, select Wurtzite from the Structure drop-down list.

b. In the Default layer frame, select In(x)Ga(1-x)N from the Material drop-down list.

c. In the Value column of the Thickness (nm) row, enter "100".
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Figure 4.14 Sample Defaults tab

d. Go to the Direct Analysis Defaults tab.

e. In the Substrate HKL field, enter "2 2 0".

NOTE: Make sure that you enter the value as 2, space, 2, space, 0.

f. In the Layer HKL field, enter "2 2 0"

NOTE: Make sure that you enter the value as 2, space, 2, space, 0.

CHAPTER 4 MAKE AND EDIT SAMPLE INFORMATION

33



Figure 4.15 Direct Analysis Defaults tab

3. Click OK to save the settings and close the window.

4. Go to Sample > New Sample. At the bottom of the screen, the New Sample Editor tab
opens with the default material of the substrate. The default substrate is wurtzite, the default
material is GaN and the default thickness is 2.0000000.

5. In the HR Parameters field of Layer Details, click the arrow.

6. In the Primary HKL or nearest surface normal direction field, enter "1 1 0".

NOTE: Make sure that you enter the value as 1, space, 1, space, 0.

7. In the Simulation reflection (HKL) field, enter "2 2 0".

NOTE: Make sure that you enter the value as 2, space, 2, space, 0.

8. Click OK.

9. In the Layers pane, click Add Layer.

10. From the Material drop-down list, select In(x)Ga(1-x)N [Wurtzite].
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11. In the Alloy Comp. x field, enter "0.1".

12. In the HR Parameters field of Layer Details, click the arrow.

13. In the Primary HKL or nearest surface normal direction field, enter "1 1 0".

NOTE: Make sure that you enter the value as 1, space, 1, space, 0.

14. In the Perpendicular distortion calculation field, select Hexagonal a plane.

15. Clear the Couple Y direction relaxation to X direction check box.

16. In the Simulation reflection (HKL) field, enter "2 2 0".

NOTE: Make sure that you enter the value as 2, space, 2, space, 0.

17. Click OK.

18. In the Layer Details pane, expand Relaxation Details.

19. In the Value (%) field, enter "50" for the relaxation of the 0001 planes.

20. In the Layer Details pane, expand Relaxation Y Details.

21. In the Value (%) field, enter "40" for the relaxation of the 1-100 planes.

22. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter "Sample D.asamxl".

c. Click Save.
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1 Analysis of this data file is described in detail in a paper published by Saito et al: Jpn J Appl, Phys 39, 5489-5495 (2000).

CHAPTER 5 USE GRAPHICS WITH AREA

SCANS

5.1 Introduction

This chapter gives 3 examples on how to manipulate area scan data. The files used in the
examples are recorded from layered materials.

The first example uses data collected from a sample which has a layer of SBTN
(=SrBi2(Ta0.7Nb0.3)2O9) on a (100) Si substrate coated with layers of silicon dioxide, titanium and
platinum. We will project a 2theta-omega/chi map as a powder scan.

The second and third examples use data collected from a sample which has an InGaAs/GaAs
superlattice on a gallium arsenide (GaAs) substrate. We will merge 2 area scans and find the
average composition of the superlattice and the parallel mismatch between the superlattice and
substrate from the merged reciprocal space map.

5.2 Project an area scan

This section gives information about how to select plot options for an area scan and how to project
a scan. The data used is file "SBTN fibre.A00". 1

 

1. Start AMASS.

2. Go to Settings > Default Area Scan Plot Settings.

3. Use these settings:

36



Figure 5.1 Default Area Scan Plot Settings window

4. Go to File > Open Scan(s).
5. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

6. Select "SBTN fibre.A00".

7. Click Open.
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Figure 5.2 SBTN fibre.A00 plotted in absolute degrees

This area map is a set of 2theta-omega scans recorded for chi values between 0 and 90
degrees. The thin film has a fiber texture. The intensity for each reflection is divided along
vertical lines in the plot. When all the intensity is projected onto the horizontal axis, a 2theta-
omega scan is made which would be recorded from a polycrystalline sample of the same
material. This scan can be used to examine the phases.

8. Go to Tools > 2-axes Scan Tools > Project to X Axis to project the map. The projected scan
is in the next available graph that contains 1-axis data. The scan name is
"SBTN fibre_PROJ_#1.ascnxl".

Figure 5.3 Projected scan with logarithmic intensity scaling

The projected data is not automatically saved. You can save it with a project or as a single scan.

9. To extract integrated vertical or horizontal scans from an area map, do as follows:

a. In the Scan List pane, select the map.

b. Move the cursor line to the line of interest. If the cursor line is not shown, click .

c. Go to Tools > 2-axes Scan Tools > Extract Horizontal Scan or Tools > 2-axes Scan
Tools > Extract Vertical Scan.

d. Enter the number of data points for the integration. The integration width is shown in the
main graph.
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Figure 5.4 Extract Data - Horizontal window

A preview of the extracted data is shown in the window. If you change the integration width,
the shown scan is immediately updated.

e. Click OK to confirm the extraction. The data are then added to the next available main
graph that contains 1-axis data.

Figure 5.5 Extracted horizontal scan

5.3 Merge area scans

This example gives information about how to merge area scans and then use the merged data to
find the parallel mismatch and the average composition of a partially relaxed superlattice on (001)
GaAs. The data used are the files "Multi_2.A01" and "Multi_2.A02". These are reciprocal space maps
of the (4 4 4) reflection from the InGaAs/GaAs multilayer and the (4 4 4) reflection from the (001)
gallium arsenide (GaAs) substrate.
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1. Go to Tools > 2-axes Scan Tools > Merge 2-axes Scans.

2. Click Add scan(s).
3. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

4. Select "Multi_2.A01" and "Multi_2.A02".

5. Click Open.

Figure 5.6 Merge 2-axes Scans window

The scans are shown in the Scan List. Click on the scan name to toggle between the scans.

6. In the Merged scan name field, enter a name for the merged scan.

7. Click Preview. The graph shows the merged data.

8. Click OK to accept the merged data. The merged data will be loaded to one of the main
graphs. The projected data is not automatically saved. You can save it with a project or as scan
data.

9. Continue with measure parallel mismatch and average composition of a superlattice. Refer to
Section 5.4. Do not close AMASS.
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5.4 Measure parallel mismatch and average composition of a

superlattice

This example gives information about how to mark and label peaks in an area scan and use the
peak positions of the substrate and layer to find the parallel mismatch and the average
composition of a superlattice. The data from the previous section is used.

1. Click  to open the Area Scan Plot Settings window.

2. From the Plot type drop-down list, select Bitmap.

3. From the Palette drop-down list, select X'Pert.

4. Select the Plot in reciprocal space (if applicable) and Maintain aspect ratio check boxes.

5. Click OK.

6. Set up parameters for the peak search:

a. Go to the 2-axes Peak Search Details tab.

b. Use these settings:

Figure 5.7 2-axes peak search details

c. Click Set smoothing details.

d. Use these settings:

Figure 5.8 Smoothing details

7. In the Scan List pane, select the scan.

8. Press F9  to do the peak search. The plot must show as follows:
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Figure 5.9 Marked peak positions

9. Manually label the substrate and layer peak:

a. Go to the Peaks Found tab.

b. For the peak with the highest intensity, select Layer from the Peak Type drop-down list.

c. For the peak with the second highest intensity, select Substrate from the Peak Type drop-
down list. The peaks are labeled "S" and "L".

10. Find the average composition, relaxation and parallel mismatch of the Ga(x)In(1-x)GaAs/GaS
superlattice:

a. Go to the RSM Results Summary tab.

b. For the substrate, select GaAs from the Material drop-down list.

c. For layer 1, select Ga(x)In(1-x)As from the Material drop-down list.

d. In the HKL column, enter "4 4 4" for the substrate and layer 1.

NOTE: Make sure that you enter the value as 4, space, 4, space, 4.

The values for the Ga composition, the relaxation and parallel d‑spacing mismatch
(fractional differences in d‑spacings) to the substrate surface are given. If the d‑value for the
substrate is known, this information can be used to find the in-plane lattice parameters of
the layer unit cell.
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Figure 5.10 RMS Results Summary tab

11. Close AMASS.
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CHAPTER 6 FIND COMPOSITION AND

RELAXATION FROM ROCKING CURVES

6.1 Introduction

This chapter gives information about how to find the composition and percentage relaxation of a
layer from 4 rocking curves. The 4 curves are supplied from a gallium indium arsenide
(In(x)Ga(1‑x)As) layer on a (001) GaAs substrate.

The rocking curves are for 004 and 224 reflections with the [110] direction horizontal with phi = 90
for scans with file names that end with "a", and phi = -90 for scans with file names that end with
"b". All 4 rocking curves show 2 peaks - the weaker peak is from the layer in all curves.

The 4 scans are the optimum set necessary to calculate relaxation from rocking curves. They are 2
symmetrical reflections, measured before and after a 180 rotation in phi. There are 2 rocking
curves that use the same asymmetrical reflection, 1 with low angle of incidence and 1 with high
angle of incidence and phi rotated by 180. For more information about approximations with fewer
rocking curves, refer to the AMASS Help.

The procedure given in this chapter is available for diamond, zinc blende and wurtzite structures. It
cannot be used for wurtzite layers on sapphire or silicon carbide substrates.

6.2 Set the defaults
1. Start AMASS.

2. Go to View > View as H.R. Diffraction.

3. Go to the 1-axis Peak Search Details tab.

4. Select Set peak to center.

5. In the Ignore peaks below (cps) field, enter "500". This is set just above the background level.

6. Make a new rule:

a. Click Add.

b. In the Name field, enter "S-L".

c. Click Add rule. A line is added to the grid.

d. Use these settings:
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Figure 6.1 Edit Peak Labeling Rules window

e. Click OK. The 1-axis Peak Search Details tab is shown with these peak labeling
parameters set. Peaks will be found and labeled in each measured scan as it is loaded.

Figure 6.2 Peak labeling parameters

7. Set the plot options:

a. Go to Settings > Default Single Scan Plot Settings.

b. From the Intensity scale drop-down list, select Logarithmic.

c. From the Intensity units drop-down list, select cps.

d. From the Show x axis as drop-down list, select Relative seconds.

e. From the Plot seconds relative to drop-down list, select 1st highest peak.
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Figure 6.3 Default Single Scan Plot Settings window

8. Click OK.

6.3 Show and print results
1. Go to File > Open Scan(s).
2. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

3. Select "GaInAs004a.d00", "GaInAs004b.d00", "GaInAs224a.d00" and "GaInAs224b.d00".

4. Click Open.
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Figure 6.4 The 4 measured scans with the marked peaks

5. Go to Tools > 1-axis Scan Tools > Relaxation and Mismatch for 1-axis Scans. The 4
measured rocking curves are now shown in the graph. The Relaxation and Mismatch for 1-
axis Scans window shows the calculated composition, relaxation and parallel mismatch of the
layer.

Figure 6.5 The 4 measured scans with relaxation and composition

6. If you want to change the combination of scans, select or clear the Use check boxes next to
the scan names. Relaxation and composition can be calculated from 3 curves or 2 curves
(which must include 1 asymmetrical scan).

7. Go to Report > Report Setup.

8. In the Available report items field, select the item that you want to include in the report.
One Axis Relaxation and Mismatch must be included.

9. Click .

10. Go back to step 2 until you have added all the items that you want to include in the report.

11. Click OK.

12. If you want to print the report, go to Report > Print Report.
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13. If you want to save the report, go to Report > Save Report To File As and select the format
that you want to save the report as.

6.4 Analyze your own data

The previous sections gave information about how to calculate the composition and relaxation
from 4 rocking curves with the default sample structure. This section gives procedures that can be
necessary when you want to analyze your own data.

6.4.1 Edit HKL values

The mismatch, composition and relaxation calculations need the HKL values for each of the curves
used in the analysis. If your scan data does not include the correct HKL information, you can use
the edit menu to give the necessary information:

1. Go to File > Open Scan(s).
2. Select the scan that you want to open.

3. Click Open.

4. Go to Tools > 1-axis Scan Tools > Relaxation and Mismatch for 1-axis Scans.

5. In the Sample's reference plane HKL field, enter the correct HKL information.

NOTE: Make sure that you enter the value as <h>, space, <k>, space, <l>.

Figure 6.6 Scan Information window

6. Click OK.

6.4.2 Use your own sample file

You can use your own sample file instead of the default sample file.

1. Go to File > Open Scan(s).
2. Select the scan that you want to open.

3. Click Open.

4. Go to Sample > Open Sample.
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5. Select your sample file.

6. Click Open.

7. Go to Tools > 1-axis Scan Tools > Relaxation and Mismatch for 1-axis Scans.

8. Select the Use materials from selected sample layers check box.

9. From the Layer drop-down list, select the layer that you want to use.

6.4.3 Use the results to update the sample file

You can transfer the values calculated in relaxation and mismatch for 1-axis scans to the sample
file when the results are shown in the results pane. Do as follows:

1. Go to Tools > 1-axis Scan Tools > Relaxation and Mismatch for 1-axis Scans.

2. Click Update Sample. The original parameters of the selected layer is overwritten.
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CHAPTER 7 FIND COMPOSITION AND

RELAXATION FROM MAPS

7.1 Introduction

This chapter gives information about how to find the composition and percentage relaxation of a
layer from 4 diffraction space maps. The 4 curves are supplied from a gallium indium arsenide
(Ga1-xInxAs) layer on a (001) GaAs substrate.

All 4 maps show 2 peaks - the weaker peak is from the layer in every map. The set of maps consists
of a symmetrical 004 and an asymmetrical 444 reflection recorded in 2 orthogonal reciprocal
lattice planes which are normal to the substrate surface. The pair of maps with phi = 0 have file
names that end with "a", the pair of maps with phi = 90 have file names that end with "b".

The 4 maps given can be used to calculate the 3 layer unit cell parameters. With 1 pair of maps
you can calculate the unit cell in 1 reciprocal lattice plane. The relaxation is assumed to be the
same in the orthogonal plane if composition is calculated from a single pair of maps. Composition
and relaxation can be calculated from a single asymmetrical map. In this case substrate surface
planes are assumed to be parallel to the same planes in the layer and the relaxation is the same in
the orthogonal direction.

The procedure given in this chapter is available for diamond, zinc blende and wurtzite structures. It
cannot be used for wurtzite layers on sapphire or silicon carbide substrates.

7.2 Set the defaults
1. Start AMASS.

2. Click  to view details for HR diffraction.

3. Go to Settings > Application Settings.

4. Go to the Direct Analysis Defaults tab.

5. In the Automatic peak marking on opening scans frame, select the Peak label check box
for Measured 2‑axis scans.
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Figure 7.1 Direct Analysis Defaults window

6. Click OK to save the settings and close the window.

7. Set the plot options:

a. Go to Settings > Default Area Scan Plot Settings.

b. From the Intensity scale drop-down list, select Logarithmic.

c. From the Plot type drop-down list, select Bitmap.

d. Select the Plot in reciprocal space (if applicable) check box.
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Figure 7.2 Default Single Scan Plot Settings window

e. Click OK.

8. Go to the 2-axis Peak Search Details tab.

9. Use these settings:
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Figure 7.3 2‑axes peak search frame

10. Set the smoothing details:

a. Click Set smoothing details.

b. Use these settings:

Figure 7.4 Smoothing Details window

c. Click OK.

11. Make a new rule:

a. Click Add.

b. In the Name field, enter "S-L".

c. Click Add rule. A line is added to the grid.

d. Use these settings:
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Figure 7.5 Edit Peak Labeling Rules window

e. Click OK. When a measured scan is loaded, peak positions are marked with crosses. The
substrate and layer peaks are marked "S" and "L" respectively.

7.3 Show and print results
1. Go to File > Open Scan(s).
2. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

3. Select "Map004a.a00", "Map004b.a00", "Map444a.a00" and "Map444b.a00".

4. Click Open. Each map will be shown in one of the graphs.

5. Make sure that the marked and labeled peaks are shown in each map.

Figure 7.6 The 4 measured scan shown with the marked peaks

6. Go to Tools > 2-axis Scan Tools > Relaxation and Mismatch for 2-axis Scans. The 4
measured maps are now shown in the graph. The results value which shown are related to the
Calculate Substrate angles check box. If the check box is not selected, the Bragg angles are
calculated from the 2theta positions of the peaks. If the check box is selected, the expected
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position of the substrate peak is calculated from the layer lattice parameter stored in the
database and the wavelength. The layer angles are calculated from substrate peak position
and the measured peak separations.

Figure 7.7 The 4 measured scans with relaxation and composition

7. If you want to change the number of scans used in the calculation, use the radio buttons
above the scan names in the Relaxation and Mismatch for 2-axes Scans window.

8. Go to Report > Report Setup.

9. In the Available report items field, select the item that you want to include in the report.
Two Axes Relaxation and Mismatch must be included.

10. Click .

11. Go back to step 2 until you have added all the items that you want to include in the report.

12. Click OK.

13. If you want to print the report, go to Report > Print Report.

14. If you want to save the report, go to Report > Save Report To File As and select the format
that you want to save the report as.
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CHAPTER 8 MAKE SIMULATIONS AND

USE AUTOMATIC FITTING OF ROCKING

CURVES

8.1 Introduction

This chapter shows the simulation and fitting functionality. You must have an HR Option License
next to the AMASS Basic License. If you do not have the HR Option License you cannot do a
simulation and automatic fitting.

8.2 Simulate with the Simulate Setup tab

This section gives you instructions to simulate a rocking curve with the Simulation Setup tab. It is
possible to edit parameters on the different tabs of the Sample Details tab to make the fit
between a simulated curve and a measured curve better.

The sample structure used is a SiGe heterojunction bipolar transistor (HBT) with 2 discrete SiGe
layers and a Si cap. Use the measured scan "SiGe.d00" in your Documents folder: ...\PANalytical
\AMASS\Examples.

Figure 8.1 The SiGe HBT structure with 2 SiGe layers

8.2.1 Set the defaults

1. Start AMASS.

2. Go to View > View as H.R. Diffraction.

3. Set the substrate as follows:

a. Go to Settings > Application Settings.

b. Go to the Sample Defaults tab.

c. In the Default substrate frame, select Diamond from the Structure drop-down list.
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d. In the Default substrate frame, select Si from the Material drop-down list. The list only
contains materials that are part of the chosen structure type.

4. Set the layer as follows:

a. In the Default layer frame, select Diamond from the Structure drop-down list.

b. In the Default layer frame, select Si(x)Ge(1-x) from the Material drop-down list.

c. If applicable, change the default values for thickness and composition.

d. If applicable, select the Use percentages to set fitting ranges check box. When this
check box is selected, you can change the percentage values that will be used to set the
fitting ranges.

e. Go to the Direct Analysis Defaults tab.

f. In the Substrate HKL field, enter "0 0 4".

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

g. In the Layer HKL field, enter "0 0 4"

NOTE: Make sure that you enter the value as 0, space, 0, space, 4.

5. In the Automatic peak marking on opening scans frame, select the Peak search check
box for Measured 1-axis scans.

Figure 8.2 Direct Analysis Defaults tab
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6. Go to the Fitting Defaults tab.

7. From the Algorithm drop-down list, select Powell (Fast).
8. From the Difference scheme drop-down list, select Sqr. Log Difference.

9. Clear the Automatically update fitted parameters check box.

10. In the Confidence analysis error percentage, enter "5".

Figure 8.3 Fitting Defaults tab

11. Click OK.

8.2.2 Make a new sample

1. Load the experimental scan:

a. Go to File > Open Scan(s).
b. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

c. Select "SiGe.d00".

d. Click Open.

2. Go to Sample > New Sample. The grid currently shows the default material for the substrate
as set in Settings > Application Defaults. If necessary, this can be edited.
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3. Add the first layer:

a. In the Layers pane, click Add Layer. The substrate layer moves down 1 row and the new
layer is the top row. The material is Si(x)Ge(1-x) as set in the defaults.

b. In the Alloy Comp. x field, enter "0.9".

c. In the Thickness (nm) field, enter "20".

4. Add other layers to the sample:

a. Select Layer No. 1 in the grid.

b. In the Layers pane, click Add Layer.

c. In the Alloy Comp. x field, enter "0.96".

d. In the Thickness (nm) field, enter "20".

e. In the Layers pane, click Add Layer.

f. From the Material drop-down list, select Si [Diamond].
g. In the Thickness (nm) field, enter "25".

h. In the Sample length (mm) field, enter "100".

5. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File name field, enter a file name.

c. Click Save.

8.2.3 Do the simulation

1. Set the default single scan options:

a. Go to Settings > Default Single Scan Plot Settings.

b. From the Intensity scale drop-down list, select Logarithmic.

c. From the Intensity units drop-down list, select cps.

d. In the Show x axis as field, select the correct setting:

• Select Relative seconds if you want to plot in seconds.

• Select Absolute angle (deg) if you want to plot in degrees.

e. If you selected Relative seconds, select an option from the Plot seconds relative to
drop-down list. The option 1st highest peak is a good selection to start with.

f. Click OK to close the window.

2. Go to the Simulation Setup tab.

3. Select the Normalise intensity check box.

4. Click  of Primary wavelength (A).
5. Select the correct wavelength. In this example, CuKa.

6. Click OK.

7. Press F2  to start the simulation. A red line shows on the graph.

8. In the Scan List pane, select the filename of the opened scan.

9. Click Use selected scan's values to adjust the start and end values.

10. Press F2  again.
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Figure 8.4 Rocking curve scan and simulation

11. Make sure that the instrument parameters are correct:

a. In the Simulation Setup tab, select Ge 220 Asym from the Monochromator drop-down
list.

b. In the Value column of the Background (cps) row, enter "10".

c. In the Beam width (mm) field, enter "1.4".

12. Press F2  again. The simulated curve now matches the measured curve better, but the peaks
of the SiGe layers are not well matched.

Figure 8.5 Simulated rocking curve

13. If you want to make the simulation better, manually edit the sample model.
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8.3 Fit with the Fitting Setup tab

Automatic fitting can be used to get a match between the measured and simulated curve. We use
2 examples:

• A SiGe HBT structure with 2 discrete SiGe layers

• A GaN/GaInN superlattice on a sapphire substrate.

8.3.1 Fit SiGe HBT with 2 discrete SiGe layers

1. Select the layer and convolution parameters to fit and its ranges:

a. Go to the Sample Details tab.

b. Select Layer No. 1.

c. Clear the Use percentages to set fitting ranges check box.

d. Use these settings:

Figure 8.6 Settings for layers 1 and 2

e. Do steps b to d again for Layer No. 2 with the same settings.

f. Select Layer No. 3.

g. Use these settings:
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Figure 8.7 Settings for layer 3

2. Select convolution parameters and its ranges for fittings:

a. Go to the Simulation Setup tab.

b. Clear the Use percentages to set fitting ranges check box.

c. In the Min. field of the Background (cps) row, enter "2".

d. In the Max. field of the Background (cps) row, enter "15".

3. Set up the fitting parameters:

a. Go to the Fitting Setup tab.

b. From the Measured scan drop-down list, select 1st highest peak.

c. From the Simulated scan drop-down list, select Substrate.

d. Select the Use smoothing check box.

e. In the Smoothing start (data points) field, enter "20".

f. In the Smoothing reduction (data points) field, enter "10".

4. Press F3  to start the fit. During fitting, only 2 curves are shown in the graphics area and the
difference plot. These are the smoothed measured curve and the current simulated curve. The
progress of the fitting is shown in the Fitting Results tab. At the end of the fitting, the final
simulated curve is shown together with the measured and the initially simulated scan. Scans
that were previously loaded in the same window will also be shown.
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Figure 8.8 Simulated and fitted curve

The fitted curve now matches the peak positions of the measured data, but there are still
differences in the intensities. Some of the values are highlighted when they are close to, but
not equal to the limit. It is not necessary to change these values.

5. To make the fit better, add diffuse scattering parameters to the fit parameters:

a. Go to the Simulation Setup tab.

b. Use these settings:

Figure 8.9 Diffuse scattering parameters

6. Press F3  to start the fit. The fitted curve now correctly matches the experimental data.
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Figure 8.10 Final fitted curve

8.3.1.1 Confidence analysis

1. Go to Simulation and Fitting > Perform Fitting Confidence Analysis. The results of the
confidence analysis are shown in the table of the Fitting Results tab. The columns Low and
High show the calculated confidence ranges of each parameter based on the error
percentage values set.

Figure 8.11 Fitting results with confidence ranges

2. If you want more information about a particular analysis, do as follows:

a. Select the parameter.

b. Go to Simulation and Fitting > Plot Parameter's Fitting Confidence.
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Figure 8.12 Fitting confidence plot with predefined error percentage line

The green horizontal line shows the predefined error percentage value. The cross sections
with the red curve give the confidence range shown in the grid.

3. Save the project:

a. Go to File > Save Project As.

b. In the File name field, enter "HR_Fitting_Example1.aprjxl".

c. Click Save.

8.3.1.2 Set up a report

1. Go to Report > Report Setup.

2. In the Available report items field, select the item that you want to include in the report.

3. Click .

4. Go back to step 2 until you have added all the items that you want to include in the report.

5. Click OK.

6. If you want to print the report, go to Report > Print Report.

7. If you want to save the report, go to Report > Save Report To File As and select the format
that you want to save the report as.

8.3.2 Fit a GaN/GaInN superlattice on a sapphire substrate

For this sample the interface between the sapphire and the GaN buffer layer is assumed to be
totally relaxed.

Figure 8.13 The sample structure for GaN.d00
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To show automatic fitting for this sample, 2 files are supplied in the AMASS examples folder:

• GaN.d00, a measured rocking curve.

• GaN_MQW.aprjxl, a project file that contains the intended layer structure and necessary
settings for fitting.

8.3.2.1 Do a simulation

1. Open the 2 files used in this example:

a. Go to File > Open Project.

b. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

c. Select "GaN_MQW.aprjxl".

d. Click Open.

e. Go to File > Open Scan(s).
f. Select "GaN.d00".

g. Click Open.

2. Press F2  to start the simulation.

Figure 8.14 Loaded data and the first simulation

The first layer peak of the simulated scan is matched to the highest peak of the measured
scan. This is because the sapphire peak is out of range of the measured scan. For this
example, we use a sample file with a total link. If you want to see the information about this
link, do as follows:

a. Go to the Sample Details tab.

b. In the Layers pane, click Link layers.
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Figure 8.15 Link Layers window

There is a total link between the 2 layers of the superlattice. This has been done to get a
good estimate of the period (the combined thickness of the 2 layers) from the satellite peak
positions. In the sample file "GaN4.s00", the period was made the same as the estimated
period and we do not want this to change during fitting.

c. Click OK to close the Link Layers window.

8.3.2.2 Fit sample parameters

1. Press F3  to start the fit. During fitting, only 2 curves are shown in the graphics area and the
difference plot. These are the smoothed measured curve and the current simulated curve. The
progress of the fitting is indicated in the Fitting Results tab.

Figure 8.16 Fitting Results

Figure 8.17 Fitting plot

2. Examine the values in the Fitting Results tab. If necessary, edit the values of all highlighted
cells in the Sample Details tab so that they are no longer the same as the current value.

3. If you changed the values, press F3  to start the fit again.

At the end of the fitting the final simulated curve is shown together with the measured and the
initially simulated scan. Scans which were previously loaded in the same window will also be
shown.

CHAPTER 8 MAKE SIMULATIONS AND USE AUTOMATIC FITTING OF ROCKING CURVES

67



Figure 8.18 The fitted curve now matches the experimental data

8.3.2.3 Confidence analysis

1. Go to Simulation and Fitting > Perform Fitting Confidence Analysis. The results of the
confidence analysis are shown in the table of the Fitting Results tab. The columns Low and
High show the calculated confidence ranges of each parameter based on the error
percentage values set.

Figure 8.19 Fitting results with confidence ranges

2. If you want more information about a particular analysis, do as follows:

a. Select the parameter.

b. Go to Simulation and Fitting > Plot Parameter's Fitting Confidence.
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Figure 8.20 Fitting confidence plot with predefined error percentage line

The green horizontal line shows the predefined error percentage value. The cross sections
with the red curve give the confidence range shown in the grid.

3. Save the project:

a. Go to File > Save Project As.

b. In the File name field, enter "HR_Fitting_Example2.aprjxl".

c. Click Save.

8.3.2.4 Set up a report

1. Go to Report > Report Setup.

2. In the Available report items field, select the item that you want to include in the report.

3. Click .

4. Go back to step 2 until you have added all the items that you want to include in the report.

5. Click OK.

6. If you want to print the report, go to Report > Print Report.

7. If you want to save the report, go to Report > Save Report To File As and select the format
that you want to save the report as.
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CHAPTER 9 MAKE SIMULATIONS AND

USE AUTOMATIC FITTING OF SPECULAR

REFLECTIVITY CURVES

 

9.1 Introduction

This chapter gives information about how to make a sample that contains a substrate and 2 single
layers, and then do a simulation and fit the sample parameters.

9.2 Prepare the program
1. Start AMASS.

2. Go to View > View as Reflectivity.

3. Go to Settings > Application Settings.

4. Go to the Fitting Defaults tab.

5. From the Algorithm drop-down list, select Powell (Fast).
6. From the Difference scheme drop-down list, select Sqr. Log Difference.

7. Clear the Automatically update fitted parameters check box.

8. In the Confidence analysis error percentage, enter "5".
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Figure 9.1 Fitting Defaults tab

9. Click OK.

9.2.1 Prepare materials in the material data file

The status bar shows "Standard.rmd" in the first box from the left to show that this is the current
database.

1. Examine the available materials:

a. Go to Sample > Edit Material Data.

b. In the DensityOnly list, select CoO.
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c. Click Edit material.
d. Make sure that the Density (g/cm3) value is correct:

• CoO, density = 6.45 g/cm3

• Fe3O4, density = 5.18 g/cm3

• SrTiO3, density = 5.1 g/cm3

e. Click OK.

f. Do steps b to e again for Fe3O4 and SrTiO3.

g. Click OK.

h. If you get the message Material data has changed. Do you want to save it?, click Yes
and then save the file.

2. If materials are missing, add them to the materials database:

a. Click Add material.
b. In the Number of elements field, enter "2".
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c. From the first Element drop-down list, select the necessary element. In this example, Co.

d. From the second Element drop-down list, select the necessary element. In this example, O.

e. Click in the Name field to see the proposed material name. In this example, CoO.

f. In the Density (g/cm3) field, enter "6.45".

Figure 9.3 Insert Material Data window

g. Click OK.

9.2.2 Make a new sample

1. Go to Sample > New Sample.

2. From the Material drop-down list, select SrTiO3 [DensityOnly]. If you want to see less
material structures in the drop-down list, do as follows:

a. In the Extras pane, click Customize editor.

b. Clear the applicable check boxes.

c. Click OK.

3. Make sure that the Density (g/cm3) is 5.1.

4. In the Roughness (nm) field, enter "1".

There are 3 columns shown at the end of the grid: refractive index components Delta, Beta
and Elect. Density. These values cannot be edited, because they are related to the selected
wavelength selected on the Simulation Setup tab. If you do not want to see these columns,
do as follows:

a. Click in the top left corner of the grid.

Figure 9.4 Location of the asterisk button

b. Clear the check boxes.
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5. Add a layer to the sample:

a. In the Layers pane, click Add Layer. The substrate layer moves down 1 row and the new
layer is the top row.

b. From the Material drop-down list, select CoO [DensityOnly].
c. Make sure that the Density (g/cm3) is 6.45.

d. In the Thickness (nm) field, enter "40".

e. In the Roughness (nm) field, enter "1".

6. Add the last layer to the sample:

a. In the Layers pane, click Add Layer.

b. From the Material drop-down list, select Fe3O4 [DensityOnly].
c. Make sure that the Density (g/cm3) is 5.18.

d. In the Thickness (nm) field, enter "10".

e. In the Roughness (nm) field, enter "1".

f. In the Sample length (mm) field, enter "20".

7. Save the sample:

a. Go to Sample > Save Sample As.

b. In the File Name field, enter "Sample 1 for AG.asamxl".

c. Click Save.

9.3 Set up the simulation
1. Go to File > Open Scan(s).
2. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

3. Select "XRR-1.X00".

4. Click Open.

Figure 9.5 XRR scan data

5. Go to the Simulation Setup tab.
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6. From the Scan type drop-down list, select Specular: Omega/2Theta scan.

7. Click Use selected scan's values. The Start (deg) and End (deg) fields will be updated with
the values of the opened scan.

8. Select the Normalise intensity check box.

9. Click  of Primary wavelength (A).
10. Select the correct wavelength. In this example, CuKa.

11. Click OK.

12. Press F2  to start the simulation. A red line shows on the graph.

13. Make sure that the instrument parameters are correct:

a. From the Monochromator drop-down list, select Divergence.

b. In the Value field of Background (cps), enter "5".

c. In the Value field of Divergence (°), enter "0.004".

d. In the Beam width (mm) field, enter "0.1".

e. Select the Use sample and beam details check box.

f. Press F2  to start the simulation.

Figure 9.6 Simulated specular reflectivity curve

9.4 Fit sample parameters

9.4.1 Set the defaults

In this part of the exercise, the fitting parameters are set for the program and the cursor is moved
to the end of the initial fitting scan range.

1. Move the cursor line to approximately 0.8°.

2. Right-click and then select Use Cursor Position to Set Segment Increments.

3. Go to the Fitting Setup tab.

4. From the Algorithm drop-down list, select Powell (Fast).

CHAPTER 9 MAKE SIMULATIONS AND USE AUTOMATIC FITTING OF SPECULAR REFLECTIVITY

CURVES

75



5. From the Difference scheme drop-down list, select Sqr. Log Difference.

6. Make sure that the Automatically update fitted parameters is cleared.

7. Select these check boxes:

• Use smoothing
• Use segmenting

8. Go to the Sample Details tab.

9. Clear the Use percentages to set fitting ranges check box.

10. Select the substrate.

11. In the Layer Details pane, clear the Fit check boxes in Density Details and Thickness
Details.

12. Use these settings:

Table 9.1 Roughness and thickness values

Layer Parameter Minimum Maximum

2,0 Thickness 5 15

2,0 Roughness 0.5 2.5

1,0 Thickness 35 48

1,0 Roughness 0.5 2.2

Substrate Roughness 0.5 1.5

13. Go to the Simulation Setup tab.

14. Use these settings:

Figure 9.7 Instrument details settings

15. Press F3  to start the fitting. Examine the green line, it must stay close to the blue line. If it
does not, the fitting parameters must be changed. For example, increase the minimum and
maximum ranges, try another difference scheme, or try another fitting method (genetic
algorithm).
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Figure 9.8 Simulated and fitted specular reflectivity curves

16. If you want to accept simulated and fitted curves, double-click them in the Scan List pane. If
you do another simulation, these curves are saved. If you do not accept the curves, they are
overwritten with the next simulation.

17. If the results are good, press F5  to update the sample with the refined parameters.

9.4.2 Confidence analysis

1. Press F6  to do the fitting confidence analysis.

2. Go to Simulation and Fitting > Perform Fitting Confidence Analysis. The results of the
confidence analysis are shown in the table of the Fitting Results tab. It will show the columns
Low and High that show the calculated confidence ranges of each parameter based on the
error percentage values set.

Figure 9.9 Fitting results with confidence ranges

3. If you want more information about a particular analysis, do as follows:

a. Select the parameter.

b. Go to Simulation and Fitting > Plot Parameter's Fitting Confidence.
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Figure 9.10 Fitting confidence plot

The green horizontal line show the predefined error percentage value. The cross sections
with the red curve give the confidence range shown in the grid.

4. Save the project:

a. Go to File > Save Project As.

b. In the File name field, enter "XRR_Fitting.aprjxl".

c. Click Save.

9.5 Set up a report
1. Go to Report > Report Setup.

2. In the Available report items field, select the item that you want to include in the report.

3. Click .

4. Go back to step 2 until you have added all the items that you want to include in the report.

5. Click OK.

6. If you want to print the report, go to Report > Print Report.

7. If you want to save the report, go to Report > Save Report To File As and select the format
that you want to save the report as.
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CHAPTER 10 MAKE A WAFER MAP FROM

A SET OF DIFFRACTION DATA

10.1 Introduction

A wafer map shows the variation in sample parameters (for example, substrate peak width or layer
mismatch) as a function of position on the wafer. A minimum of 1 series of rocking curves,
recorded from an array of points on the sample, is necessary as input. More than one series of
different experimental data can be used. For example, to combine the analysis of rocking curves
recorded at different hkl reflections and related reciprocal space maps.

There are 2 sets of example data used in these exercises. The first set is an array of rocking curves
recorded on the (002) and (102) reflections from a thick gallium nitride layer on a silicon wafer. The
change in position of the substrate peak is used to show the distortion of the wafer while the peak
widths of the rocking curves is measured for the structural quality of the epilayer. A sample file is
not necessary for this analysis. This type of wafer map can be applied to all substrate materials.

The second set is from a strained (relaxation = 0 %) gallium indium arsenide phosphide layer on an
indium phosphide substrate with an indium phosphide cap. The variation in layer mismatch is
calculated from the variation in the separation of the substrate and quaternary layer peaks. A
sample file is necessary for this analysis.

10.2 Make a wafer map to show distortion and structural

quality

The measured sample was a 100 mm silicon (001) wafer with a deposited layer of gallium nitride. A
regular array of rocking curves was collected on the (002) and (102) GaN reflections with a general
batch program in Data Collector.

These files are supplied for this example:

• X_Y_1.xrdml: (002) rocking curve data

• X_Y_4.xrdml: (102) rocking curve data

 

1. Start AMASS.

2. Go to Settings > Application Settings.

3. Go to the Wafer Map Defaults tab.

4. Click Set wafer outline.

5. In the Orientation (°) field, enter "180".

6. Click OK.

7. In the Calculations to perform grid, select the default.

8. Click Edit.

9. Use these settings:
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Figure 10.1 1-axis peak position calculation

10. Click OK to close the window.

11. Click Add.

Figure 10.2 1-axis peak FWHM calculation

12. Click OK to close the window.

13. Go to the Direct Analysis Defaults tab.

14. Select the Peak label check box for measured 1-axis scan in the Automatic peak marking
on opening scans frame.
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15. Click OK to close the Application Settings window.

16. Set the 1‑axis peak search details:

a. Go to the 1-axis Peak Search Details tab.

b. Select the Set window size automatically check box.

c. Select Set peak to peak center.

d. In the Rules grid, select Default.

e. The description must read S, GaN: 1st Highest in Intensity. If this is not correct, edit the
rule.

17. Go to Wafer Map > Generate Wafer Map.

18. In the Current project details frame, make sure that the 1D Peak Labelling Settings are
correct.

Figure 10.3 1D Peak Labelling Settings

19. In the Calculations to perform frame, make sure that the calculations are set correctly.

Figure 10.4 Calculations for Wafermap1

20. Save the project:

a. Click Save Project File.

b. In the File name field, enter "Wafermap1.aprjxl".

c. Click Save.

21. Click Next.

22. Click Open Files and Analyze.

23. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples\Wafermap1.
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24. Select all files.

25. Click Open. The analysis is automatically done and the results are shown.

Figure 10.5 Results of wafer map analysis

The status of the results is shown in the Status column. If necessary, review and correct the
result for each X or Y position:

a. Select a coordinate.

b. Click Plot Scan(s).
c. Move the cursor to the correct position.

d. Right-click and then go to Define Main Cursor As > Peak to correct the peak position.

e. Click OK.

26. Click Finish to continue with the wafer map results representation. The Wafer Map Results
window shows the results and gives different choices to show the results.

27. Click Wafer Plots to see the positions of the measured rocking curves.

CHAPTER 10 MAKE A WAFER MAP FROM A SET OF DIFFRACTION DATA

82



Figure 10.6 Results of wafer map analysis as bitmap plot with values

The mean, the minimum and maximum of the calculated data and the standard deviation are
shown in the bottom right corner of the wafer map result.

28. If you want to see a different plot type, select it in the Plot Type frame. Contours is only
available for data on a regular grid.

29. Save the results:

a. Click Save Results.

b. In the File name field, enter a file name.

c. Click Save.

10.3 Make a wafer map to show mismatch variation in

quaternary layer

The measured sample was half of a 2‑inch indium phosphide (001) wafer with a heteroepitaxial
quaternary (gallium indium arsenide phosphide) layer with an indium phosphide cap. There are 36
individual 004 rocking curves scans given. These were recorded for a 9x4 rectangular array of
points. The mismatch is calculated from the substrate-layer peak separation with information
about the substrate and layer materials from the sample file.
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The sample was installed on the MRD cradle. The coordinates were X = -1, Y = -2 for the center
point of the full 2‑inch wafer.

These files are supplied for this example:

• InP_Q.d00 to InP_Q.d35: 36 rocking curves in a 4x9 grid

• InP_Q.asamxl: the sample file

 

1. Start AMASS.

2. Go to Sample > Open Sample.

3. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples\Wafermap2.

4. Select "InP_Q.asamxl".

5. Click Open.

6. Go to the 1-axis Peak Search Details tab.

7. Click Add.

8. Add a rule with these settings:

Figure 10.7 Edit Peak Labeling Rules for Wafermap2

9. Click OK to close the window.

10. Go to Wafer Map > Generate Wafer Map.

11. Add these calculations.
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Figure 10.8 1-axis peak FWHM calculation

Figure 10.9 1-axis strained composition calculation

12. If there are other calculations in the list, remove them.

13. Save the project:

a. Click Save Project File.

b. In the File name field, enter "Wafermap2.aprjxl".

c. Click Save.

14. Click Next.
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15. Click Open Files and Analyze to open all files for the analysis.

16. Select the files "InP_Q.d00" to "InP_Q.d35".

17. Click Open. The analysis is automatically done and the results are shown.

Figure 10.10 Results of wafer map analysis

The table shows the x‑coordinates, y‑coordinates, scan names , status of the analysis, peak
widths and gallium compositions.

18. Click Finish to continue with the wafer map results representation. The Wafer Map Results
window shows.

19. Add information about the wafer shape:

a. Click Wafer Outline Details.

b. In the Radius (mm) field, enter "25".

c. In the X Offset (mm) field, enter "-1".

d. In the Y Offset (mm) field, enter "-2".
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Figure 10.11 Setup Wafer Outline window

e. Click OK.

20. Show and print the maps for the peak width:

a. Click Wafer Plots.

b. Click Contours. The layer gallium composition is shown.
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Figure 10.12 Map of gallium composition

21. Save the results:

a. Click Save Results.

b. In the File name field, enter a file name.

c. Click Save.

22. Go to Report > Report Setup.

23. In the Available report items field, select the item that you want to include in the report.

24. Click .

25. Go back to step 2 until you have added all the items that you want to include in the report.

26. Click OK.

27. If you want to print the report, go to Report > Print Report.

28. If you want to save the report, go to Report > Save Report To File As and select the format
that you want to save the report as.

10.4 Wafer map analysis with AMASS Controller

The wafer map analysis can also be done automatically with AMASS Controller. This software is
installed with the AMASS installation.

The AMASS Controller monitors the number of XRDML files in a selected folder. If the number of
files is the same as the specified number in the controller software, the files are moved to
the backup folder. The number is specified by the measurement strategy of the wafer map in Data
Collector. Then AMASS Controller reads the project file that contains all settings and parameters of

CHAPTER 10 MAKE A WAFER MAP FROM A SET OF DIFFRACTION DATA

88



the analysis followed by each measurement file. The analysis is done with the given parameters
and a wafer map report is made that can be printed and saved.

If you want to use the controller software, a project file is necessary. These project files were made
in the previous sections. Refer to Section 10.2., 10.3.

 

Set up an automatic wafer map analysis as follows:

1. On the Windows Start menu, go to Start > All Programs > PANalytical AMASS >
AMASS_Controller.

2. In the Folder to watch field, select the folder where Data Collector saves each scan data file
of a wafer map. Make sure that the folder exists.

3. In the Backup folder field, select the correct folder.

4. In the Number of files to count before wafer map procedure, enter the number of files
that must be in the folder before the automatic analysis starts.

5. If you want to get a report of the analysis, fill in the necessary fields.

6. If you want to make sure that all information is filled in correctly, click Test.

7. Click Start watching folder.

Figure 10.13 AMASS Controller
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CHAPTER 11 DIFFUSE SCATTER

11.1 Introduction

This sample used in these exercises has a superlattice structure that contains 10 periods of GaAs
and AlAs with an interface roughness of 0.5 nm and a lateral correlation of 200 nm. In the first
exercise, a reciprocal space map is simulated with the settings contained in a sample file. The
sample file is supplied with the software. In the next exercise, the vertical correlation settings are
changed to show the influence on the simulation pattern of the vertical correlation of the
roughness between the layers.

11.2 Set up the simulation
1. Start AMASS.

2. Go to Sample > Open Sample.

3. Go to C:\Users\User.Name\Documents\PANalytical\AMASS\Examples.

4. Select "QSG11.asamxl".

5. Click Open.

6. Go to View > View as Reflectivity.

7. Go to the Simulation Setup tab.

8. From the Scan type drop-down list, select Coplanar RSM to simulate a map to see the effects
of vertical radiation.

9. From the Algorithm drop-down list, select DWBA (Distorted Wave Born Approximation).

10. Press F2  to start the simulation. The progress of the simulation is shown in the status bar.

Figure 11.1 Simulation of reciprocal space map of periodic structure
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11. Click  to open the Area Scan Plot Settings window.

12. From the Plot type drop-down list, select Bitmap.

13. From the Interpolation factor drop-down list, select 6x.

14. Clear the Maintain aspect ratio check box.

15. Click OK.

Figure 11.2 Simulation after bitmap interpolation

11.3 Examine the influence of vertical correlation
1. Go to the Sample Details tab.

2. Go to the Diffuse Scattering and GISAXS Details tab.

3. From the Correlation type drop-down list, select Fully correlated.

4. Press F2  to start the simulation. The progress of the simulation is shown in the status bar.
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Figure 11.3 Simulation after bitmap interpolation and fully correlated

Because of the correlation of roughness of the interfaces, the clearest feature is the
concentration of the intensity on the equidistantly placed RDS (Resonant Diffuse Scatter)
sheets in the reciprocal space map. In this example, the RDS sheets are the horizontal green
lines. They show that there is a vertical correlation between the roughness of the interfaces.
This is a "normal" example of how you can quickly see these effects.

5. If you want to see more details, select a smaller step size:

a. Go to the Simulation Setup tab.

b. Select a smaller step size.

c. Press F2  to start the simulation. The simulation can take longer to complete.

d. If the simulation takes too long, press F4  to stop the simulation.
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CHAPTER 12 AUTOMATE YOUR

DIFFRACTION MEASUREMENTS AND

ANALYSES

12.1 Introduction

It is possible to automate your analyses by with either Automatic Processing Program (APP)
supplied as an add-on with Data Collector, or directly with AMASS from the command line. You can,
for example, make a shortcut.

This chapter shows 2 simple examples with the command line. It is also possible to use scripts. For
more information about scripts, refer to the Automatic Processing Program Help.

12.2 Print scan data with Automatic Processing Program

This example shows how to print out scan data immediately after it has been collected with Data
Collector.

1. On the right of the taskbar, right-click the Automatic Processing Program icon  and then
select Rules.

2. In the Measurement program type field, select the correct program type. In this example,
Relative scan.

3. In the Command field, enter the path name to run AMASS: "C:\Program Files (x86)\PANalytical
\AMASS\AMASS.exe".

4. In the Arguments field, enter "%XMLFILE% /p".

"%XMLFILE%" identifies the full path and file name of the measured file.

"p" identifies that the scan must be printed.

5. Select the Active check box.

6. Click Add to Rules List.
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Figure 12.1 Rules for Data Collector

7. Click OK.

12.3 Fit scans automatically with AMASS's command line
1. Open an editing tool. For example, Notepad.

2. Enter this code:

"SET AppName="c:\Program Files (x86)\PANalytical\AMASS\AMASS.EXE""

"SET FolderName="C:\XRD Data"

"SET Project-File=%FolderName%\HR_Fitting_Example1.aprjxl""

"SET ScanFile=SiGe.d00"

"%AppName% %ProjectFile% %FolderName%\%ScanFile%" /fit:%FolderName
%FittedScan1.x01",%FolderName%\Fitted.aprjxl" /s:%FolderName%\FitReport.pdf""

3. If necessary, update the file paths or make the folder C:\XRD Data and then copy the files
"HR_Fitting_Example1.aprjxl" and "SiGe.d00" to this folder. Refer to Chapter 8.

4. Save the batch file as "run.bat".

5. Open Command Prompt:

a. Press ⊞ Win  + R .

b. Enter "CMD".

c. Press Enter .
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6. Change the directory to the directory where the batch file is located. In this example, enter "cd
C:\XRD Data".

7. Press Enter .

8. Enter the command "run.bat".

Figure 12.2 Change directory command line

9. Press Enter . The batch will run. When it is done, the report is saved to the folder C:\XRD
Data.

10. Exit Command Prompt:

a. Enter "Exit".

b. Press Enter .

12.4 Command line specifications

The command line interface can be used to do different analyses of X‑ray scattering data. Enter a
command as follows:

"AMASS.exe [<files>] [<options>]"

where "<files>" is a list of filenames separated by spaces. The file type is specified by its file
extension.

Parameter Description

Scan file One experimental scan file (.xrdml, .dnn, .xnn, .ascnxl, .asc, .znn)

Sample file One sample file (.asamxl)

Initialization file One initialization file (.ini)

Database file One database file (.amatx)

Enter options as follows:

"/<option name>[:<option value>]"

Options must be separated by at least 1 space character.
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Option name Option value Description

p :<Printer> (optional) Print the built-in report (Report > Print Report) that has been set up
to a specified printer. If the printer is not specified, the default printer
is used. If the printer is specified, the syntax must be as follows:
<PrinterName>:[Driver]:[File]
The program stops when printing is done.

nologo  Start AMASS without the splash screen.

fit :<Files> Start fitting of specular or high-resolution diffraction data. Fitting of
diffuse scattering curves is not supported.
 
<Files> is a comma-separated list of file names where output files will
be written to 1 sample file and/or 1 simulated scan and/or 1 project
file. If a file name already exists and it is not read-only, it will be
overwritten. If the file is read-only, the file will not be written and the
program stops with exitcode=1.
 
A sample file, or project file and scan file is necessary. You do not have
to load the sample files if you want to use default settings. The
program stops automatically when fitting is done.

res :<options> There are 3 result options (peak grid, results summary and RSM result
summary) for single scan analysis. It is possible to call multiple options.
Each call starts with /res.

s :<Files> Report files (.pdf, .rtf, .html, .xml).

wmafolder :<Folder> Load all files in the folder and map wafers.

wmafiles :<File1>,<File2>, …
<FileN>

Load the list of individual comma-separated files and map wafers.
Add a filename with an .xml extension to save wafer map results to a
file with that name.

wmaopen :<File> Open and show a wafer map results file. It must have the
extension .xml.

xslt :<File> Generates and saves a result file (.html, txt) based on an xslt transform
file.

Example 1:

"AMASS.exe xxx.xrdml xxx.aprjxl /fit:FittedScan.x00, FittedSam-ple.asamxl, FittedSettings.aprjxl /
s:FitReport.pdf /p: /nologo."

Starts AMASS and opens scan data (.xrdml) and a project file (.aprjxl). Then, the scan data will be
fitted with the sample model and fitting settings of the project. The fitting results are saved and a
PDF report is made.

Example 2:

"AMASS.exe Scan.xrdml /p /nologo."

AMASS starts, opens the scan data file and prints a default report to the default printer.

NOTE: You can do automatic analysis of similar data in a simple way with AMASS Controller
software. Refer to the AMASS Help for more information.
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