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2 Introduction

This is version 5.50 of the RTSizer application software. The software is tested and supported on the
following Microsoft Operating Systems: Windows NT 4.0™ (service pack 6a and higher), Windows 2000™
Pro (service pack 4 and higher) and Windows XP™ Pro (service pack 1a or higher). Windows 2000™ Pro is
the recommended platform. The software is provided on one auto-loading compact disc (CD).

3 Instrument Compatibility

The RTSizer v5.50 software is back compatible with all previous releases of RTSizer v5.xx. The changes
made to the software in this release are to support the Spraytec instrument only.

4 Functional Features

4.1 Planned Additions
4.1.1 21CFR11 Support

The security requirements of 21 CFR Part 11 are more stringent than previously required. In order to comply
with these, the Access Level security system previously provided within the RTSizer software has been
replaced with a new security system. This provides:

e Independent security system from the Windows NT™ security system, allowing multiple users to use
the Spraytec system without the need to log in and out of Windows NT™.

e Fully configurable users and groups.

e Fully compliant with 21 CFR Part 11 requirements
'11.200 Electronic signature components and controls’ and
11.300 Controls for identification codes/passwords’

e Encrypted passwords.

e Encrypted security settings file.

e Login and out of the application without shutting it down.
e Continuous use check.

Audit trail functionality is provided within the software so that an external auditor can review the
measurement process. This includes:

e Auditing of security events such as logging in and out of the system.

e Auditing of main software functions.

e Auditing of measurement record creation, editing, and deletion.

e Audit trail viewing and export to ASCII for review.
Support for Electronic signatures is provided through the use of Adobe Acrobat. Details of the 21CFR11
features included in the software can be found in the 21CFR11 user guide included on the software CD-ROM

(21CFR Part 11 User Guide for Spraytec (MRK535-01)). Full information on the use of Adobe Acrobat®
can be found in the technical note “Creation of Digital Signatures (MRK532-01).pdf. Finally, the document
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“21CFR Part 11 Compliance Guide for Spraytec (MRK536-01)" provides some background information
regarding 21CFR11 and the Spraytec software.

4.2 Requested Additions and Changes.

The following software additions and changes have been implemented in RTSizer v5.50:

Malvern
Software
Change Description Comments
Request
Number
2146 Global settings file developed to store measurement settings. Improvement
2179 RTSizer fails to work when data directory is set to read-only Fixed
2625 Security problems found in RTSizer v5.41 Fixed
2668 Temp file not removed following flash-mode measurements Fixed
2669 Sgggrt file header is repeated throughout an export file when data filtering is Fixed
2670 \?iigve;/el—éifstory display format changed to allow relative measurement times to be Improvment
2748 Audit Trail file location does not default to the correct directory. Fixed
2901 System settings are not recalled when logging in as a non-administrator. Fixed
2996 Date / Time Stamping in 21CFR11 mode should use an unambiguous format. Improvement
As default th ri m should not recall th rname of the | r
o e o otrecalhe semame of e BSLSCT groyenry
2999 Data Reporting Interval incorrect when using data filtering / grouping options Fixed
3020 Nasal Spray Macro required to specify the Fully Developed phase. Improvement
3021 Add support for Numerical Validation of the software Improvement
The flash mode settings need to be stored in the record file in a more robust
3022 way. Improvement
The software does not always recall the correct default measurement and :
3025 . . Fixed
display settings.
Need to change report formats so that the averaging method used when
3027 . . - Improvement
reporting results is consistent across all reports.
3289 Error flag in PCL record stays permanent even when the software is rebooted Fixed
3464 Sgpport requireq for Adobe Acrobat v5 and v6 in order to provide an Electronic Improvement
Signatures solution.
3535 Provide an option to not allow PDF file to be re-named when printing to PDF. Improvement
3606 Noise and background update period editing should be controlled by the security Fixed
system.
Measurement and display settings files must not be overwritten when in :
3607 H1CRRIL mode, Fixed
3609 The software registry settings are accessible to non-administrators Fixed
3688 The software should default to text file format when exporting data Improvement
3689 The software 'should use a default export file name that is the same as the Improvement
current PCL file name.
3730 Remove statistics table from particle size history chart printed report. Improvement
3784 Add contents of the cover page to the top of the PCV table report. Improvement
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Malvern
Software
Change Description Comments
Request
Number
3790 f;r;)r;tl?sg — header information overlaps the measurement date for average PSD Fixed
PCV averages should not be reported when the PCV definition changes within :
3791 Fixed
the selected data range.
3906 Custom refractive indices are not displayed on reports if the PCL file is on a Fixed
different hard drive to the RTSizer software.
3984 Security client updates — enable the display of accounts which are locked-out Improvement

and disabled accounts with the Security Configuration view.
3985 Automated reporting of fatal errors in the program direct to Malvern Instruments Improvement

RTSizer v5.50 contains the following software additions and changes, which were implemented in RTSizer
v5.41:

Malvern Software Change

Reguest (SCR) Number Description Comments

2565 Allow time history printing and averaging in the case where  Implemented
the selected range includes measurements at greater than
100% transmission.

RTSizer v5.50 contains the following software additions and changes, which were implemented in RTSizer
v5.40:

Malvern Software Change

Request (SCR) Number Description Comments

2043 Changes export function to export time in seconds into a Implemented
separate column.

2047 Change software messages for background and size Implemented
measurements so that they are less confusing for Spraytec
customers.

2143 Add the option to include an information header in any Implemented
exported files.

2145 Add an export and import function for the flash mode Implemented
measurement settings.
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4.3 Deletions

Software modules relating to the use of the RTSizer software for process measurements have been deleted
from RTSizer v5.50. In addition, all references to Process Control Outputs (PCOs) have been removed.

5 Known Bugs

There are no known bugs at the time of this release. If you suspect that you have discovered a bug, you
should report this to Malvern Instruments detailing all aspects of the symptoms.

6 Known Issues

6.1.1 English Language Only

The changes made to the software are only for the English-language version. If the software is run on
French, German or Japanese version of Windows then the text that is inherited from previous versions of the
software will appear in the correct language but new text will appear in English.

6.1.2 No Support for Insitec

The changes made to the software are to support the Spraytec instrument only. The modules used for
process application such as the valve and process controllers and RTSizerX have not been modified or
tested for use with RTSizer v5.50.

6.2 Re-installation of 21 CFR part 11 support

Removing an earlier version of RTSizer 5.x with 21 CFR part 11 support will remove the enabling key
information. After RTSizer v5.50 is installed you will have to re-enable 21 CFR part 11 support by using the
Tools->Install Feature Key command and typing in the same feature key code you used for RTSizer v5.4x.
Please contact your Malvern Representative if you no longer have the required code.

6.3 Security access rights with NTFS

With the Windows NT file system (NTFS) it is possible to secure folders and files so that non-administrators
have limited access. The file ‘c:\rtswin\settings\security.cfg’ contains the RTSizer security data and should be
protected from change by all users other than the administrator. It is recommended that only the RTSizer
administrator logs in as Windows administrator; all other RTSizer users should be logged in as normal
Windows users. Note that the other files in the ‘settings’ directory must be given full access to all users.
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7 Distribution Media

RTSizer v5.50 is contained on a single self-installing CD-ROM. The installation process has been fully
automated by the industry standard software installer InstallShield™. Any fault during the installation process
will be detected and the user is notified. The installation process has been tested on all the supported
configurations of operating system.

8 Installing the Software

8.1 System Requirements

The software requires an IBM compatible computer with a Pentium Class Processor (300MHz or faster), 3
Gigabytes of free hard disk space, 128Mbyte Memory, CD-ROM and 1024x768 display in order to operate
correctly. 1 free serial port and 1 free full-length ISA slot is required when running the software on the
computer system which is to be connected to the Spraytec instrument. As mentioned above, the software is
tested and supported on the following Microsoft Operating Systems: Windows NT 4.0™ (service pack 6a and
higher) and Windows 2000™ Pro (service pack 4 and higher) and Windows XP Pro (service park la or
higher).

8.2 Standard Installation From CD-ROM

All data is the user’s responsibility. It is good practice to backup all data files on a daily basis. It is also good
practice to backup all data before installing new application software.

Note: Windows NT /2000 / XP will not allow an installation if the user does not have Administrator access.
This is in line with Microsoft's Logo policy and is standard practice.

This is v5.50 of the RTSizer software suite and is for Spraytec instruments only. In earlier versions of this
software some of the component modules had separate installation programs. In this version the flash
measurement module and multiple scattering module are automatically installed.

Before starting the install you should remove any earlier v5.xx version of RTSizer. In Windows Control Panel
select the Add/Remove Programs icon. In the Add/Remove Programs window select the 'RTSizer' option and
click 'Add/Remove’. The RTSizer software will be removed. Answer 'Yes' to any questions about removing
DLLs from the system directory. Repeat the remove operations for the 'RTSizer Flash Mode' and 'RTSizer
Multiple Scattering Module' if these are present in the program list.

Put the RTSizer v5.50 CD in the drive. The CD should auto-start but if it does not use Explorer to start the
application SETUP.EXE in the root directory of the CD. In common with the earlier versions of RTSizer this
software will be installed in the folder C:\ARTSWIN.

The install program may need to re-boot your PC up to two times. If the setup program does not
automatically re-start after re-booting use Explorer to run the SETUP.EXE program in the root directory of
the CD to continue the install process.

The install program puts a shortcut on the desktop and two shortcuts in Start->Programs->Malvern
Instruments->RTSizer menu - one for normal use and the other for starting the software in simulation mode.
There is also a shortcut for showing the RTSizer help.

Note: The Uninstall Shield has a list of programs and files which it originally installed and it can therefore
correctly delete them. This means that it cannot delete your data files as they will not be on the list of files to
be uninstalled.
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8.3 Installation from Floppy Disk
For installation on a PC that does not have a CD-ROM drive, you should follow the steps listed below:

1. Copy the contents of each named disk directory (i.e. disk 1, disk 2, etc) from the ‘144MB’ directory on
the installation CD-ROM onto some similarly labelled floppy disks.

2. Putdisk 1 into the floppy drive of the target computer. Using Windows Explorer, select the floppy drive
and double-click on ‘Extract.exe’.

When requested change to the next disk.

When the setup program has been extracted it will start automatically. Follow the on-screen instructions
in order to install the RTSizer software

9 New Software Features

A number of new features have been added to the RTSizer software (v5.40 and higher) in order to allow it to
be operated in a 21CFR Part 11 compliant environment. The features associated with 21CFR11 and the new
RTSizer security system are described in separate reference documents included on the software installation
CD-ROM. In addition, improvements have been made to the data reporting, data export, measurement
parameter recall and averaging functionality within the RTSizer software. These are described in detail below
with instructions on their implementation. These features are new to RTSizer v5.50.

Any feedback should be reported to Malvern Instruments via email to helpdesk@malvern.co.uk or by
telephoning the Helpdesk directly on +44 (0)1684-891800. Please have the serial number of your Spraytec
system and the software version to hand when contacting the helpdesk.

9.1 Data Export Template Improvements

The data export process used to export time history data into a spreadsheet program has been improved to
allow more flexibility and easier spreadsheet formatting.

To use the export feature you first need to select the range of results you wish to export from the time history
using the yellow cursor. The export process is started using the File->Export Data menu command. You
must choose the data to be exported in the next dialogue box (either chose the Range you selected from the
time history; All the data currently in the active data file; all the data currently viewed on the Screen or just
the Current result). Then, at the next dialogue box select to export the data to a text file by changing the file
type. This will then bring up with following dialogue box:
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Select Format of Text Expork File

7 Yersion 5.2 Text = Py
) P5 Cancel

@ Comma separated values | [~ ppy

" Tab separated values

[ Seconds in separate I Psp
colunin
[ Include header ™ Scattering

[ High precision

From this dialogue you can select the following output formats:

Version 5.2 Text — This outputs the data in the same format as RTSizer v5.20. This is provided to offer
compatibility with any external macros you may have written to process v5.20 export data. Output of the
Process Control Variables (PCVs) or Particle Size Distributions (PSDs) at each time point is available.

Comma Separated Values — Produces a text file following the standard CSV format. This allows for
easier formatting in external software packages. Using this format you can select to export the PCVs,
PSDs or the Scattering Data associated with each time point. It is possible to include a file header
containing all the important instrument and analysis parameters in order to improve data traceability.
Finally, the time for each point is exported in hrs:min:sec format as standard. However, for flash mode
measurements it is possible to separate the seconds into a separate column. This makes it easier to
process time-points where the time in seconds is expressed to an accuracy of 4 decimal places.

Tab Separated Values — Produces a text file following the standard Tab-Delimited format. Again, this
allows easy formatting in external software packages. The same output options are available in this
format as for the CSV format.

Seconds in separate column — Produces a text file with the time-stamp selerated into one column
containing the Hour and Minute reference and a separate column containing the Seconds reference.
This allows for easier plotting of data produced using Flash mode.

Include Header — This option includes the measurement header information at the top to the data file
when enabled.

High Precision — This option has been included to support software numerical validation. Enabling this
option increases the precision of the exported values to avoid rounding errors. The format of the export
file is also changed when exporting PSD data. As default this option should be disabled.

PCV — Enabling this option outputs the PCV values specified for each point in the selected measurement
range into the export file.

PSD - Enabling this option outputs the particle size distribution information for each point in the selected
measurement range into the export file.
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e Scattering - Enabling this option outputs the scattering data recorded for each point in the selected
measurement range into the export file.

9.2 Time history display format

Flash and continuous mode measurements may now be displayed on the time-history display with times
relative to the start of the measurement or trigger point, rather than with an absolute time stamp. Use the
View->Relative Timing command with a time-history window selected to toggle the display between
absolute and relative times. The command is disabled when old measurement files created using earlier
software versions are loaded.

1 Default Layout

i Time History Cnly
| Record Wiews Only Show times
relative to start.

[wiew Tools  Window  Help I

I
! v Toolbar Command is

v Status Bar disabled on old
_ ¥ Messages measurements

Maximize on Cpen

v Relative timing

Figure 1 - View Relative Timing menu command

In the flash measurement mode the times reported using the “Relative Timing” option are shown with
reference the to measurement trigger.

In continuous measurement mode the relative times are set relative to the last “measurement start” event.
The time axis cannot show multiple zero times therefore the zero time is only shown for the most recent
measure start. Times before this point show only show the date part of the absolute time stamp. Times show
in the cover page, PSD and scattering data windows (displayed in the top two display windowpanes when a
time history file is loaded) show the times relative to when the currently selected measure sequence was
started.
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Figure 2 - Size history chart - relative times (top) and absolute times

PSD windows created from a time history either through double-clicking a PSD view, or through calculating
an average, may also be switched between showing relative or absolute times (select the View->Relative
timing command when the PSD view is active). Relative times are identified by showing them with a trailing
‘(R)" as shown in Figure 3.

=1 E3
23 Jan 2004 10-02:27 (R)

Relative time for \
20.0 an average

between 10
‘ ‘ ‘ ‘ seconds and 2

minutes 27

seconds after the
start of the
measurement /

Figure 3 - Part of a PSD window showing relative times for an average

9.3 Flash measurement - averaging part of a measurement

After a flash measurement it is possible to create an average of the time-history data over a user-specified
interval. In previous versions of RTSizer this could be done automatically after the flash measurement, but
only over the whole of the measurement. RTSizer v.50 adds the ability for the user to enter the time interval
over which the average should be calculated (Figure 4). This functionally has been specifically added to aid
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users in defining the “full developed” phase when making nasal spray measurements, although it has wider
application.

Gart and stop times (in \

milliseconds) over which the
average PSD is calculated.
Times are relative to the start
of the measurement.

Use ‘Average all’ option to

v Reduce data? v PCL File average all the measurement

S

Analyziz

v #wveraged PSD [ Average al Filename |average

Start time [mz] I Stop time [mz] 10

Figure 4 - Part of the flash measurement dialog box showing the averaging options

After the measurement has been done an average over a selected interval may be calculated by using the
Calculate->Average menu command. In RTSizer v5.50 if the ‘relative timing’ option is enabled (Figure 1)
then it possible to set the times in the record selection dialog relative to the measurement start (Figure 5).

Gzart and stop times (in \

seconds) over which the
average PSD is calculated.
Times are relative to the

Selection Range start of the measurement
when the ‘View->Relative

165 OF 166 Records Marked timing’ option is selected.

Start Date 0611403 Stop D at

[DD/MM A (DD /MM A

Start Time 00,0040 Stop Time | 00.3340

Mate : Use the time histary controls to select a range or
manually enter the time zpan.

Figure 5 - Part of the record selection dialog showing the relative start and stop time fields
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9.4 Global SOP settings file

In previous versions of RTSizer the settings that configured the measurement and how the result was
processed could be saved to and recalled from a series of settings files; where each configuration section
had its own file type (display settings, flash mode settings, reduction control settings, etc..).

RTSizer v5.50 still allows each part of the configuration to be stored separately, including the ability to save
default settings. However, a new global settings file format is now provided, allowing users to save a single
SOP file that can then be recalled in order to set up an entire measurement procedure. Access to importing
and exporting global settings files (file extension ‘*.rtss’) is enabled when the time history or flash mode
measurement windows are selected. Settings are exported using the File->Export Settings->All Settings
menu option (figure 8) when a time history view is active or the File->Export All Settings option (figure 9)
when the flash mode measurement window is active. Settings are recalled using the File->Import Settings
or File->Import All Settings menu options. The table below shows which configuration items can be saved
and recalled for each window type and the security permissions which need to be enabled to allow users to
export settings.

Setting Imported / Exported Imported / Exported Security Permission
with with required to export setting
Time-history active  Flash mode active
Reduction control settings Yes Yes Edit reduction control
settings
Flash measurement No Yes Edit flash-mode
settings measurement settings
PCYV definitions Yes Yes Edit process variable
definitions
Background duration Yes Yes Edit background and noise
measurement duration
Measurement update Yes No Edit Time-History
period measurement update
period
Display settings for the Yes No Edit Time-History display
Time-history chart settings
Setting of ‘standard Yes Yes Edit ‘standard average’
average’ (see Section setting

9.3.2 of this document)

If security permissions are set so that the current user may not export one or more of the settings types then
these settings are not included in the ‘all settings’ file. If the user has no permission to export any settings the
‘All Settings’ menu command is disabled. Global settings files exported with one window type active may be
imported with the other window type — settings that are not relevant to the active window type are left
unchanged when this occurs.

The name of the current imported global settings file is saved in the notes tag field in the same way as the
flash mode settings. To protect the settings file entry in the notes tag there is a new security permission ‘Edit
Tag Notes’ with the RTSizer security system - if this is not set then the Notes field in the Edit->Tag dialog
box is disabled.
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Figure 6 - Import and Export Measurement Settings with Time-History window active
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Figure 7 — Import and Export Measurement Settings with Flash Mode window active

9.5 Requirement for consistent averaging

When a set of results is averaged the statistics of the selected PCV values are calculated and the
concentration-weighted average, standard deviation and maximum and minimum values are reported on the
Process Variables page. The Cover Page report view also reports a set of “Standard Values”, calculated
from the averaged particle size distribution, which includes some parameters that may be selected within the
Process Variables table. Because of the different method of calculation the “Standard Values” averages may

not agree with the equivalent averaged Process Variables.

In the new version of RTSizer a checkbox on the record selection dialog (see Figure 8 displayed by the
Calculate->Average menu command) controls the visibility of the standard values on the Cover Page and

other reports and how the PCV values are averaged.
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Figure 8 - Record Selection dialog showing the standard averaging control

The table below describes how a particle size distribution (PSD) average is calculated

Standard Values on reports and Calculation of average
Cover Page view PCVs
Concentration-weighted
average of the PCV values

‘Standard Average’ control

Clear No reported at each point in the
time history.
Checked Yes Calculated ferOSthhe average

The equivalent of the previous version of RTSizer is for the ‘standard average’ checkbox to be clear (the
default) except that now the ‘standard values’ are not shown because they may be different to the
equivalents in the PCV table. If the average is calculated with the ‘standard average ‘ checkbox set then the
PCV statistics table has a comment added specifying that the calculations are based on the averaged PSD
(Figure 9).

Transmission (%) 967 £
User notified that
D[4][3] (prm) 40.70 average PCVs are
derived from the
D[3]0] {prn) 1.74 average PSD

171 Records Averaged (from average PS0)

Figure 9 - Part of the PCV statistics table showing additional note
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Standard Average may also be selected within the flash mode measurement dialog as an option when
creating an average PSD after a flash mode measurement (Figure 10).

Standard
average option
on the Flash
Mode window

v PCL File nzl3
™ dverane al Fi.
] Stop time [mz) |':'-1 [+ Standard average

Figure 10 - Part of the Flash Mode window showing the 'Standard Average' checkbox

The ‘Standard Average’ setting is saved in the global settings file and users may be prevented from changing
the setting by using a new security policy — the Edit ‘Standard Average’ security setting.

9.6 Export of time history records
When exporting time-history records using the File->Export Data menu command the state of the file save
dialog box is changed:

e The file name defaults to showing the root name of the PCL file rather than being empty.

e The directory to which the file will be saved defaults to the standard data directory (usually
C:\RTSwin\Data).

e The default export format is a text file rather than a PCL file.

9.7 Printed time-history chart no longer has statistics table

In previous versions of RTSizer if you selected a range of records in the time-history chart and selected File-
>Print or Edit->Copy menu option, the time-history chart was printed (or copied as a metafile) with a legend
table which included the statistics of the selected records. This was often viewed as confusing, especially
when producing data reports which included in PCV report. RTSizer v5.50 no longer prints a table of average
record statistics with the time-history chart as default. To print a table of record statistics use the Calculate-
>Average command and print the PCV report separately.

Note that in this case the old behaviour of the software can be restored in order for the averages to be

reported as part of the time history printout. If this is required please contact your local Malvern
representative.

9.8 The PCV printed report table format
In RTSizer v5.50 the print of the PCV table now also includes the contents of the cover page (i.e. standard

values, tag documentation notes, measurement values and settings and calibration settings are added). The
PCV table as selected as a view on the time-history or PSD windows is unchanged.
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9.9 Error reporting

In the rare event that the RTSizer program has a fatal error and crashes the dialog, shown in Figure 11, is
displayed which allows technical information about the crash to be either e-mailed directly to the helpdesk at
Malvern Instruments or saved to be e-mailed later.

RTSIZER MFC application

RTSIZER MFC Application has encountered a problem and B
needs to close. We are sony for the inconvemence.

If you were in the middle of something, the information you were working on might
be lost.

Pleasze tell Malvern Instruments about this problem.

WWe have created an eror report that pou can zend to uz. “We will reat this report
az confidential and ananymoL.

To help uz diagnoze the cause of this emor and improve this software, please
dezcribe what you were doing when this eror occurred, and send this report o us.

Describe what pau were daing when the errar accurred [optional];
| did something wrong J

. of

To zee what thiz report containzs, click here.

[~ | can e-mail from thiz PC Send Error Bepart | Don't Send |

Figure 11 — Error report dialog

9.10 21CFR11 Functions
9.10.1 21 CFR11 Enabled Mode

The 21 CFR Part 11 options within the software have to be enabled using an encrypted “feature key”. Entry
of the key is achieved using the Tools-Install Feature Key menu option. Entry of a valid key will enable 21
CFR Part 11 mode once the software has been restarted. The key is unique to each system and can be
obtained on request from Malvern Instruments. Basic security options are available without entry of the 21
CFR11 feature key. Note that when upgrading the software from v5.4x to v5.50 users will need to re-
enter the feature key in order to enable 21CFR11 mode. This is due to changes in the way the security
settings are stored.
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9.10.2 Recall of last user at login

Earlier versions of RTSizer remembered the user that last logged in and showed that user’s login name in
the login dialog the next time RTSizer started. This contravenes 21CFR Part 11 as this provides possible
fraudulent users with one of the two pieces of information required to identify a user. Recall of the last user’s
login name is now controlled from the Tools->ER/ES Settings dialog box and can therefore be disabled
(Figure 12).

Configure ER/ES options

Acrobat Settings
Adobe® Acrobat POF file output directan:

|E:\F|TSWin"\.-’-'«crobat Resultz Browse. .

[ Allovs the EDF file name to be chanoed before zaving

Security Settings Set this option to allow the
[~ Enable Continuous Usze Check user to Change the name of
the PDF file before it is

_|:| saved (not recommended)

[ Show last uzer name at logon

Audit Trail 5 ettings Set this option to show
Audit Trail file output diree the last users’ name in
the logon dialog (not —

CARTSWin'dudit Trai

recommended)
Beagin new Audit Trail file:
{(* Each Day " Ewem 3 months
" Each'wWeek " Ewem B months
" Each Manth (" Each'fear
Ok | Cancel Help

Figure 12 - ER/ES options dialog box showing new features.

9.10.3 Updated Security Display

In previous version of RTSizer it was not possible for administrators to easily identify when user accounts
had been disabled or locked out due to possible fraudulent activity. The Security Configuration display has
therefore been updated in RTSizer v5.50 such that locked-out users are identified with a padlock icon
whereas disabled users are shown with a red cross.
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Figure 13 - Part of security configuration dialog showing disabled and locked users
9.10.4 Option to disallow changing the name of PDF files

RTSizer v.5.50 can be integrated with Adobe Acrobat in order to provide a method of electronically signing
electronic records within a 21CFR11 compliant environment. The name of the PDF file created by Acrobat is
automatically generated from the name of the measurement file being printed. In previous versions of
RTSizer a file save dialog box was displayed just before the PDF file was saved to allow the user to change
the name of the output file. This is no longer recommended and by default the generated PDF filename is
always used. A new option is provided in the Tools->ER/ES Settings dialog box (Figure 12) to enable the
display of the file save dialog box if users wish to be able to change the PDF output file name.

9.10.5 Date/Time stamping of measurements

To prevent confusion about day/month/year order and 12/24 hour clock, most places which show a date and
time within the RTSizer v5.50 software now use a format where the abbreviated month name and full 4-
character year is used with the time in 24-hour format. Note that these times often have decimal seconds (4
decimal place accuracy for flash mode measurements).

Date and time stamps are used by the software when saving various files (e.g. audit trail files, PDF files and
backup PCL and DAT). In these cases the order of day, month and year comes from the Windows regional
settings and the time is in 12-hour format with AM/PM indicator. Note that the separator characters between
date and time elements are fixed to be compatible with file-naming conventions.

Note that the only place where a fixed numerical date format is used in the software is when selecting a
record range in the dialogue boxes associated with the File->Print, Edit->Records and Calculate-

>Average menu options. In these places the dialog boxes emphasise the expected order and format of date
entry (Figure 14).
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Format and order
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1681 Of 162 Recaords Marked

Start Date 0&/171.403 Stop Date
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Start Time 10:1E:49.456 Stop Time  |10:16:43.778

0641103

Figure 14 - Part of the record selection dialog showing date entry fields

10 Bug Fix Details

10.1 Loading read-only size history files

In earlier versions of RTSizer, the opening of size history files required users to have write access. If the files
were security protected or marked read-only then they could not be opened. RTSizer v5.50 will open read-
only PCL files for viewing. The file may be saved to a new name but the original file will not be changed.

10.2 Removal of ‘Temp’ files

If a flash measurement is made to a named PCL file then a temporary file named ‘Tempx.pcl’ (where x is a
number) is created. In previous versions of RTSizer this temporary file was not deleted after the
measurement was completed. This bug has been fixed in v5.50.

10.3 Exported size history data has repeated headers

When a flash measurement was exported as a text file using RTSizer v5.4x repeated headers could appear
even though the measurement details had not changed. In RTSizer v5.50 header blocks are not repeated in
the exported text files unless the ‘Index Group Tag’ option is enabled in Flash Mode.

10.4 Using RTSizer when not a Windows administrator

The user who installs the RTSizer software must be logged in to Windows as an administrator. The windows
administrator should also configure the security in RTSizer if required. In the previous versions of RTSizer if
a normal Windows user was logged in then the RTSizer settings were not saved when RTSizer was closed.
This is because the settings were saved in files in the WINNT directory; a directory that is normally protected
from change by non-administrators. When RTSizer v5.50 is installed the settings files are moved from the
‘C:\WINNT’ directory to ‘C\RTSWIN\SETTINGS'. All users must have write access to this directory. This
allows all of the software and hardware settings to be recalled for all users.
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10.5 Errors in flash measurement group averaging

The flash mode measurement options allow the flash measurement to be split into equal interval groups, with
the average of each group being reported in the time history. In earlier versions of RTSizer it was possible
that consecutive groups would be merged leading to inconsistent averaging. The latest RTSizer corrects this
problem, although it is still possible to get the last group in a measurement with a shorter duration than the
preceding group in the case of the measurement duration not being a multiple of the group interval.

10.6 Saving default settings

In previous versions of RTSizer the default settings (those set by the ‘Save Default’ buttons in the configure
dialogs) were saved in the WINNT directory. This directory is protected from change by Windows users who
are not administrators (NTFS file system only). This meant that the default settings were not properly
recalled for non-administrators. RTSizer v5.50 saves configuration and default settings in the
‘C:\RTSWIN\SETTINGS' directory. The Windows administrator must make sure all users have write access
to this directory so that any default settings can be recalled correctly.

10.7 Flash measurement notes should not be overwritten

The flash measurement uses part of the tag notes field to store the important flash mode settings for display
in the report pages. In previous versions of RTSizer if the user-entered notes were too long some or all of the
flash settings were lost. In RTSizer v5.50 the user is limited to entering 40 characters of tag notes — leaving
room for the flash settings to be appended. There is no such restriction when a continuous (i.e. non-flash)
measurement is made.

To further protect the flash mode settings there is a new security permission (Edit Tag Notes) within the
RTSizer security system. If this is not set then the Notes field in the Edit-Tag dialog box is disabled.

10.8 Registry settings for instrument are not accessible by non-
administrators

The Spraytec instrument controller card settings are stored as part of the Windows system registry. The
registry is normally write-protected to users who are not Windows administrators. In the new version of
RTSizer the installer creates this registry section and changes the security permission so that all users have
write access. This means that all users of RTSizer who have permission to “Access the system controller
window” within the software security system may change the system controller address and interrupt
number. It also ensures that the default configuration is correctly recalled for all users.

10.9 Printing —title header overlaps date
In some circumstances the header title of an averaged PSD window would overlap the range of date-times

over which the average was made. The software now senses that an overlap would occur and in these cases
reduces the size of the font used.

10.10 Problem with display of refractive index values

In earlier versions of RTSizer if a custom calibration (CAL) file was generated then it was possible that the
refractive index values were not displayed in the cover page view. This was because the refractive index
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values for custom CAL files are extracted from the files (the refractive index values of standard CAL files are
derived from the name of the file). The system searched for the CAL files in the RTSWIN\CAL folder on
whatever was the current drive; if data was loaded from a network drive then that would be the current drive,
not drive C:. In version 5.50 the CAL files are now always searched for in C\ARTSWIN\DATA.

10.11 21CFR11 functions

10.11.1 Noise and Background update period under control of security policy

In the previous version of RTSizer the update period dialog box for the noise and background measurement
windows was permanently disabled when security control was active. Changing the update period is now
under control of the "Edit background and noise measurement duration" security policy.

10.11.2 Disable overwriting of settings files in 21CFR11 mode.

If 21 CFR part 11 mode is active it is no longer possible to overwrite existing settings files. A message box is
displayed advising the operator that 21 CFR part 11 policy does not permit the overwriting of files. The
operator is then given the opportunity of choosing a new filename.

10.11.3 Audit trail file location

In the previous version of RTSizer the audit trail files (with an ADT file extension) were saved in the root
directory. In this version the files are created in the ‘C:\RTSWIN\AUDIT TRAIL’ directory. If an old version of
RTSizer is upgraded the old audit trail files are not moved or deleted from the root directory.

10.11.4 Security password expiry

In previous versions of RTSizer if the security system was configured so that if a user’'s password expired
after a set time then it was not possible to force the user to change the password at the next logon. Also the
system warned of password expiry much earlier than designed. These bugs have been fixed in v5.50.
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