
 

 

1 Software Update Notification (PSW0060-7.40) 

Software Update Notification 
PSW0060-7.40 (RTSizer v7.40) 

Abstract 
This document details the release of PSW0060-7.40 RTSizer version 7.40 software for the Insitec process particle sizer; it 
covers software issues fixed and new features introduced. This information is required to perform a risk analysis to determine 
if the software should be installed. In this risk analysis the benefits of the new features provided and resolved software issues 
must be weighed against the risk of new issues that may be introduced to vital areas of the software or possible changes to 
the results of future analysis. Installation instructions are provided. 

Installation 

Recommended System Requirements 
The recommended requirements for running this software are highlighted in the table below: 

 

Feature Specification 

Processor Type 3GHz Core 2 Duo processor (or equivalent) 

Memory 4 GB 

Hard Disk Storage 250Gbyte 

Additional Storage Media CD-ROM drive 

Display Resolution 1024 x 768 

Connectivity 1 RS-232 port 

Operating System Windows XP Professional TM with Service Pack 3 installed 

 Windows 7 Professional (32 and 64 bit) 

Although the software has been tested using Windows XP Professional and Windows 7 (64 bit). Windows 7 Professional (32 
bit) is preferred, as this operating system was used for software alpha testing. 

 

Note: This software has not been tested for compatibility with Microsoft Windows VistaTM  
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Installation Instructions 

Installing the WinHelp component 
RTSizer software uses the WinHelp (WinHlp32.exe) component to display the help files with .hlp extensions.  

Starting with the release of Windows Vista and Windows Server 2008, Microsoft has decided to no longer include 
WinHlp32.exe as a component of the Windows operating system. 

To use the RTSizer software help files on Windows 7, the WinHelp component may need to be installed. To verify if the 
WinHelp component is already installed, go to the control panel from Windows start menu and select ‘Programs -> Programs 
and Features’ option. Click on the ‘View installed updates’ link in the left pane to view the installed updates. If the WinHelp 
component update is already installed on your computer then the entry for KB917607 will be present in the list as seen 
below: 

 

 

 

Please refer to the Knowledge Base article, "Windows Help program (WinHlp32.exe) is no longer included with Windows" for 
more information.  

 

http://support.microsoft.com/kb/917607
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To obtain the WinHlp32.exe download for Windows 7, visit the following Microsoft Web site: 

http://go.microsoft.com/fwlink/?LinkId=166421 

There are two different files available for 32 Bit and 64 Bit versions of Windows 7. 

Windows 7 (64 Bit)  Windows6.1-KB917607-x64.msu 

Windows 7 (32 Bit) Windows6.1-KB917607-x86.msu 

 

Download and install the appropriate WinHelp component depending upon the operating system being used. 

Installing the software 
The user must have administrator privileges to install the software. The software will only install on Windows 7 or Windows 
XP. Windows 7 is the recommended platform. The software is distributed on one CD-ROM.  

This version is a full version of the RTSizer software; it may be used with Malvern Link v1.31 or later. 

The CD should auto-start. If it does not, use Explorer to start the application Start.exe in the root folder of the CD. 

If RTSizer v6.00, v7.00, v7.10, v7.11, v7.20 or v7.30 is installed you will be asked to uninstall it first. 

RTSizer v7.40 will use any shortcuts and configurations from v7.xx versions of RTSizer 

The setup program will ask you the options you want to install, as shown below: 

  

 

http://go.microsoft.com/fwlink/?LinkId=166421
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If the Insitec instrument is connected to the PC you are installing the software on then check the 'Install the RTSizer 
application' option. If the instrument is attached to another PC on the network (and RTSizer is installed on that PC) and you 
are going to install Malvern Link on this PC then clear the 'Install the RTSizer application' option and check the 'Remote 
operation support' option. 

The last page of the setup program gives you the option of starting RTSizer to make an instrument configuration. If you do 
not choose this option you can make a configuration by choosing Start->Programs->Malvern Instruments->RTSizer-
>Configuration Manager. In the Configuration Manager main window type in a configuration name, a description, your 
company name and then choose the serial communications port for the instrument. You can also choose if you want the login 
dialog box to appear every time RTSizer is started. Click OK, the main RTSizer window will open and attempt to connect to 
the instrument.  

The configuration manager will create a shortcut on your desktop, which you can then use to start RTSizer. 

Uninstall Procedure  
The software can be uninstalled using the standard Add/Remove Programs feature in the Windows ‘Control panel’. 

Using the New Features in RTSizer v7.40 

Setting the rolling average period remotely 

The SetAveragePeriod RTSizer7X command is a new command for setting the rolling average period (in seconds) in the 
software.  

SetAveragePeriod 

Set the rolling average period for the PSD measurement. 

Syntax 

Function SetAveragePeriod(nDuration As Short) As Short  

 

Parameter Description 

nDuration The rolling average period value in seconds. 

 

Returns 
•   1 = Rolling average period value is set 

•   0 = Failed to set the rolling average period 

• -1  = Not Connected 

• -2  = Connection timed-out  

• -3  = Value can not be set during the active PSD measurement 

• -4  = Security failure - No measurement permission or TakeControl not issued 

Remarks 
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To view a graph of the averaged data values on the Time History Display, select the Average size and 
transmission view. The average period specified is the number of seconds over which the data is 
averaged. 

The rolling average period can not be set if the PSD measurement is active. 

TakeControl command must be issued before this command is used. 
 

Fixed Issues 
The following Software Change Requests (SCRs) have been implemented in this version of the RTSizer software 

SCR 
Number 

Description Improvement or Fix 

8058 Make changes for Windows 7 compatibility Implemented 

9282 A standard user cannot load a .psh file created by an administrative user Fixed 

9349 Error message during start up phase with multiple sessions of RTSizer Fixed 

9350 Add a new RTSizerX method for changing the rolling averaging period Implemented 

9385 Restriction on change to PCV variables should not be so restrictive Fixed 

 

Known Issues 

Windows 7 Firewall Settings 
Windows 7 contains a new firewall system which is designed to prevent applications from accessing the remote 
communication functionality used by the RTSizer software. As such, when the RTSizer software is first run, a security alert 
message box will appear informing you that operation of the software has been blocked: 
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In order to enable operation of the software, you need to be logged on as an administrator. Tick the first checkbox (Private 
networks) within the alert dialog and deselect the second checkbox (Public networks). Then press the Allow 
access’button. 

Files created by using export functionality do not support additional measurements 
If a range of records are exported to a new file using the menu command File->Export and saved as a data file then the 
Database size for the new file is 0 bytes. This means that if a measurement is subsequently started in the file then the 
software will flash a message saying "PSH file is full" and begin deleting some exported records. 

The solution to this problem is to set the size of the Database (via Edit->Database...) for the file to a reasonable size e.g. 
250MB before carrying out any measurements. 

Using RTSizer Help on Windows 7 

The RTSizer help will not be available to the users on Windows 7 if the WinHelp component update is not installed. The error 
message ‘Failed to launch help’ will be displayed if the user tries to browse through the RTSizer help.  

The Installation Instructions section describes the WinHelp component installation procedure. After installing the update it 
should be possible to browse through the RTSizer software help.  

Restart after configuration change 
If the configuration is changed from the system parameter window then it may be necessary to close and re-start RTSizer 
before the changes take effect.  

Saving particle size history files 
It is not advisable to save data directly to a network drive as network traffic may delay file writes causing measurements to be 
suspended. If the measurement period is longer than one measurement per second then it should be safe to save on a 
network drive.  

Note that the RTSizerX commands that have a PSH filename as a parameter assume the file is in the default data directory 
(e.g. ‘C:\Users\Public\Documents\Malvern Instruments\RTSizer\Data’ on Windows 7 OR ‘C:\Documents and Settings\All 
Users\Documents\Malvern Instruments\RTSizer\Data’  on Windows XP)  

Fast measurement 
Measurements made with a 0.25 millisecond update rate may very occasionally have records with a ‘Zero scan count’ error. 
Using a fast PC with no other running programs seems to reduce the problem. If you need to transfer data using RTSizer7X 
use the ‘async’ commands to read PSH data after the measurement has been completed.    

Running RTSizer on laptop computers 
Experience at Malvern Instruments has shown that running RTSizer on laptop computers may cause reliability problems in 
communications between the computer and the optical head. If you get problems of random disconnection and connection 
messages in the RTSizer message window try disabling the power saving features on the laptop computer. If this does not 
work we have found that using a USB to serial converter in place of a direct serial connection often solves the problem.  

New File Locations 
Version 7.40 like 7.30 uses new locations for many files. Upgrading from an earlier version of RTSizer will move any existing 
files to the new locations: 

In the table below: 

<common data> refers to the common settings folder.  

For Windows 7 this is typically ‘C:\ProgramData\Malvern Instruments\RTSizer’ and  
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for Windows XP this is  ‘C:\Documents and Settings\All Users\Application Data\Malvern Instruments\RTSizer’. 

Note that the ‘C:\ProgramData‘ or ‘C:\Documents and Settings\All Users\Application Data’ folder is normally hidden from 
Windows Explorer. 

 

<shared docs> refers to the shared documents folder. 

For Windows 7 this is typically ‘C:\Users\Public\Documents\Malvern Instruments\RTSizer’ and  

for Windows XP this is typically ‘C:\Documents and Settings\All Users\Documents\ Malvern Instruments\RTSizer’ 

 

<program files> refers to the root folder where the program is installed.  

For Windows 7 and Windows XP this is typically ‘C:\Program Files\Malvern Instruments\RTSizer’ 

 

File Old location New location 

RTSizer_2000.ini 

Main settings file 

Windows <common data> 

DefaultPrinter.rtp 

Default printer settings 

<program files>\Program <common data> 

Security.cfg 
Security settings 

<program files>\Data <common data> 

Current.exp 

Current File export settings 

<program files> <common data> 

RefractiveIndex.ini 

New particle and dispersants 
settings 

<program files>\Configuration <common data> 

Configurations 

Folders containing configuration 
data 

<program files>\Setup <common data>\Setup 

Scattering Matrices 

Files of scattering models 

<program 
files>\Configuration\Scattering 
Matricies 

<common 
data>\Configuration\Scattering 
Matricies 

Imaging Models 

Files of imaging properties 

<program 
files>\Configuration\Imaging 
Properties 

<common 
data>\Configuration\Imaging 
Properties 

 

All of the above files and folders are automatically copied to their new locations during the installation. 

 

Other files created by RTSizer – by default – will have new locations. These are only suggestions and the files may be saved 
in different locations by changing the settings within RTSizer. The files are not automatically moved to the new locations. 
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Folder Old location Suggested New location 

Data 

Measurement data 

<program files>\Data <shared docs>\Data 

Acrobat Results 

PDF files  

<program files>\Acrobat Results <shared docs>\Acrobat Results 

Backup 

Backup of measurement files 
before editing  

<program files>\Backup <shared docs>\Backup 

Audit Trails 

Audit trail data  

<program files>\Audit Trails <shared docs>\ Audit Trails 

 

Windows Security Issues 
The RTSizer software must be installed by a user who is a member of the Windows Administrators group but any user should 
be able to run the RTSizer software 

Settings and data files have now been moved to locations where any user should be able to read and write to them. 

Language Switcher and Windows Locale 
The Language Switcher program will only change the language settings of RTSizer if the Windows locale settings are not set 
to the selected language. 

For example if the PC is running English-language Windows XP and you want to run RTSizer with a French-language user 
interface then the Windows locale setting (Start->Control Panel->Regional Options->General) must NOT be “French 
(France)”  

Optimum Screen Display 
RTSizer has been optimised to look best with a screen resolution of 1024 x 768 with 16, or higher, bits of colour and with 
Windows normal small fonts.  

Memory Leak on Windows XP SP2 
Opening and closing measurement file windows many times leads to a small GDI (graphics memory) leak. This is an issue 
with Windows XP SP2 but generally will only become a problem if running continuous automated sequences of 
measurements over several days. The current solution is to run Windows with the ‘Classic’ theme. 
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